PHP at 7.3.23, but getting an error message to update PHP

Since updating to 4.0 I’m getting a PHP error in the root level error log on my server that my PHP version needs to be updated. But It’s at 7.3, which is confirmed in System Check:

PHP version >= 7.2.5: :heavy_check_mark: 7.3.23

[26-Nov-2020 18:24:01 UTC] Error in Matomo: To run Matomo you need at least PHP version 7.2.5 Unfortunately it seems your webserver is using PHP version 7.1.33. Please try to update your PHP version, Matomo is really worth it! Nowadays most web hosts support PHP 7.2.5.

Any insight into the situation would be most appreciated.



Do you get this error during archiving?

I think this is happening:

You are running php-fpm (or php-apache) 7.3 which is serving the website (as the system check reports correctly).

But you still have 7.1 installed and when running the archving job (from cron), you still use the old php-cli which shows the error.
So I’d recommend you to check your crontab and see if you are calling the right php binary.

Thanks Lukas!

I think you are correct. When I looked at the cronjob it says:

/opt/cpanel/ea-php71/root/usr/bin/php /…

System check confirms I’m using php7.3.23 , so just want to confirm what to change the cronjob to?

Should it be “ea-php73” for that php version? Or more detailed like “ea-php7323”

Thanks again!


That depends completely on your host. When in doubt, ask them, but you could also just try out ea-php73 and see if it works.

Will do. Thanks again!

Hi there
I’m my own hoster and I run Vestacp on the Debian 9 VPS.
Still at updating to Matomo 4.04 I get this:
To run Matomo you need at least PHP version 7.2.5
System runs on php 7.4 and I purged 7.2 still no change.

1 Like


The easiest way to be sure the version is correct is by temporarily creating a file containing


in the matomo directory and access the URL from the browser.

Well thx unfortunately
I just get

as an output


Did you name the file something.php?

well kinda
php.txt let me try a fantasy name

It needs a .php file extension

ok well that’s me.

Build Date May 14 2020 09:11:51
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php/7.0/apache2
Loaded Configuration File /etc/php/7.0/apache2/php.ini
Scan this dir for additional .ini files /etc/php/7.0/apache2/conf.d

Still the error message is

To run Matomo you need at least PHP version 7.2.5

Unfortunately it seems your webserver is using PHP version 7.0.33-29+0~20200514.36+debian9~1.gbp126f6f.

php -v says 7.4 though


It looks like your webserver is using php7.0.
Keep in mind that php for your webserver and php-cli on the commandline is separate.

any idea how to put the webserver to 7.4 or where its determined which php to use?

1 Like


If you use nginx change the line that looks like fastcgi_pass unix:/var/run/php/php7.4-fpm.sock. I don’t know Apache, so I can’t help you there.

thx still a filename would be helpful
On Terminal I get

php -i | grep “Loaded Configuration File”
Loaded Configuration File => /etc/php/7.4/cli/php.ini


I don’t know your webserver setup, so it is hard to give specific tips. The person that set up PHP on your server can probably help more.

Matomo doesn’t choose the PHP version, but the other way round: You set up your webserver (e.g. Apache) to a PHP daemon of your choice (e.g. php-fpm or php-apache). So to make sure Matomo runs with the right PHP version, you need to make sure your webserver forwards php requests to the right php daemon.

Hi Lukas, thx
I know that but where do I find the file which determines apache cli config if
Loaded Configuration File => /etc/php/7.4/cli/php.ini ist not the cli config file.

I’m not a sys admin, I have about 4 years in different set ups on linux server plus desktop.

1 Like


When you call php from the command line it executes php-ini which as you can see is set up correctly to use php 7.4.

I unfortunately have never used Apache before, so I can’t help you at all there, but I’d recommend you too look through all files in /etc/apache2/ to maybe find a line that specifies the php executable.

Maybe this also helps:

Hi Lukas
output on
rpm -qa | grep php is nill

I have
php 7.0
php 7.2
php 7.3
php 7.4
in /etc/apache

neither do I have /etc/httpd