PHP 7 support?


#1

PHP 7.0.0 Alpha 2 has just been released and next month the first PHP 7.0.0 Beta 1.

How well would Piwik fair right now with PHP 7.0.0 ?

thanks


(Matthieu Aubry) #2

Hi there,

We haven’t tested it yet, but Piwik should work fine with PHP7. if it does not, please create issues on the tracker: Issues · matomo-org/piwik · GitHub


(Matthieu Aubry) #3

Update: we’re actively working on PHP7 compatibility: see discussion in Full PHP7 compatibility · Issue #8689 · matomo-org/piwik · GitHub


#4

thanks Matt


#5

@matthieu what about tracker-proxy php 7 support php 7 support · Issue #12 · matomo-org/tracker-proxy · GitHub