Page Overlay stuck in "Loading"

Hello, my client says that sometimes Page Overlay works fine for him, but most of the time is stuck in “Loading”

I’ve already checked this guide https://matomo.org/docs/page-overlay/#page-overlay-troubleshooting and I can’t solve the problem.
I’ve already tried with different browsers, no extensions activated, no VPNs

Even your demo site is stuck in Loading (Yesterday I see it for the first time working, but today is again stuck)

Hi,

It is still working for me on https://demo.matomo.org/index.php?module=Overlay&period=month&date=today&idSite=62#?l=https$3A$2F$2Fdivezone.net$2Fdiving$2Fbali$3F__enterprise_demo$3Ddemo.matomo.org$26__enterprise_demo_idsite$3D62

Can you check the browser’s developer tools for errors in the JS console.

Update: It works in Firefox, but doesn’t work in Chrome it seems. I’ll look into it

Hi,

This is kind of working like expected:

When I try to open the page in Chrome it breaks with the following error:

Uncaught DOMException: Failed to read the ‘localStorage’ property from ‘Window’: Access is denied for this document.

Looking up in the Chrome docs


this happens because Block third-party cookies is enabled in the Chromium settings (it seems to be by default when starting a fresh browser.

So it is kind of expected when one does not allow websites to access the data of other websites that the Page Overlay (which integrates one website into another) doesn’t work properly.

I’ll nevertheless create an issue to see if there is maybe a workaround for this.

1 Like

Done in

Hello, I’ve tried to disable “Block third-party cookies” feature on Chrome and it still stuck.

I got this from my browser console:

Chrome:

Firefox:

Hi @Lukas, is there any update on this issue? We are looking forward to knowing if there is finally related to block third-party or not. We would need a workaround for this or any plan when is going to be fixed. Is part of the functionalities that we are using on our servers and we are waiting for the issue to be resolved.
Thanks!

Hi,

Nothing new in https://github.com/matomo-org/matomo/issues/16762

If you are interested in this feature, it would be amazing if you could contribute a fix (or look into the issue on how this could possibly be circumvented).

I’m encountering this issue in Chrome, Firefox and Safari even with all blockers disbaled. I’ve tested on my own sites and using the demo link provided above. I do see some Content Security Policy errors that could be related. Is there a simple patch for this, even if temporary and isolated to a specific server?

https://demo.matomo.org/index.php?module=Overlay&period=month&date=today&idSite=62#?l=https%243A%242F%242Fdivezone.net%242Fdiving%242Fbali%243F__enterprise_demo%243Ddemo.matomo.org%2426__enterprise_demo_idsite%243D62