Page loading is extremely slow


Running on Windows Server 2019 in a 2 server setup - one for Matomo and one for MySQL. As a web server I am using apache.

After some usage and rather low traffic the front end is nearly unreachable. It can take up to minutes to load up. Same when accessing directly from server via localhost. The performance counters on both servers are fine plenty of CPU, disk space and fee memory.

My system is not public to the internet
I am using matomo version 4.15.1
I have set up task scheduler

Could anyone suggest what I should be looking into.

Thank you

Hi @Bao_An_Hoang
In the configuration file, try to disable the Internet access:
enable_internet_features = 0

…“enable_internet_features = 0 to the [General] section of your config/config.ini.php file.”

1 Like

After opening the firewall, go to the addresses: (getting notified when a new release is available including security releases), (for the one-click update to work), (for the Marketplace).
Set enable_internet_features = 1

But my website loads still very slowly. After clicking on marketplace, the following error appears.

Hi @Bao_An_Hoang
@melbao and myself suggested to set enable_internet_features = 0. You have set to 1.