Overlay not working after 1.11.1 update

I recently updated from 1.10.1 to 1.11.1 through the auto-update mechanism but now page overlays aren’t working anymore

Stuff I tried:

  • ‘Moving’ Piwik to the same domain as the website (used a symlink), also updated the tracking code to reflect the change
  • Using another browser (stock chrome v25) and clearing cache after every other step
  • Re-uploading piwik with the exception of the config directory
  • Clearing tmp directory
  • Tried multiple websites and pages
  • Confirmed tracking is working (my visits in Chrome show up in the visitor log)
  • Updated Piwik tracking code to the newest version on multiple websites
  • Checked server logs for errors, found nothing
  • Deactivated and re-activated the overlay plugin
  • Tried updating to beta but the update check returns that no update is available after setting allow_upgrades_to_beta = 1 in [Debug] and changing the UpdateCheck_LastTimeChecked in db to something old

Still getting the message “The Page Overlay session couldn’t be launched yet.”

Funny thing I noticed just now is that Google Chrome shows a 403 error for index.php when trying to expand a folder on the “Actions => Pages” page. This only happens when using the symlinked url and isn’t solved by setting enable_trusted_host_check=0
I don’t think this has anything to do with the other problem but might be interesting.

Any idea’s or vague hunches?

What is the php.ini memoery setting? What php version are you using? Did you install any new browsers plugins or Javascript on your site web pages?

PHP Version 5.3.3

Hmmm, I tested again and got a simple website with old tracking code working in Chrome. When testing again on the main website, I disabled all JS and the WP-Piwik plugin for Wordpress and inserted the default piwik 1.11.1 trackingcode. This actually worked!
Found out the the problem for the WP-Piwik usage is that the Piwik api returns the folowing code:

url: lspvirn/?module=API&method=SitesManager.getJavascriptTag&idSite=1&period=&date=&filter_limit=&token_auth=76c472b088315d91edd4496ca42e29ef&expanded=&url=http%3A%2F%.domain.nl&format=PHP
(note: lspvirn is a random folder name I made Piwik available on for this domain for testing purposes)

s:849:"<!-- Piwik -->
<script type="text/javascript"> 
  var _paq = _paq || [];
  (function() {
    var u=(("https:" == document.location.protocol) ? "https" : "http") + "://domain.nl/lspvirn//";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    _paq.push(['setSiteId', 1]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0]; g.type='text/javascript';
    g.defer=true; g.async=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);

<noscript><p><img src="http://domain.nl/lspvirn/piwik.php?idsite=1" style="border:0" alt="" /></p></noscript>
<!-- End Piwik Code -->

You probably won’t notice but when comparing with the code in Piwik’s controlpanel, the url includes an extra / !

I’ve added “$strTrackingCode = str_replace(’//”;’, ‘/";’, $strTrackingCode);" on line 364 of wp-piwik.php as a workaround.

I can’t understand why other websites that are not using the wp-piwik plugin weren’t working earlier but they are working now without having changed anything (except for the chrome version probably)
Also, It still doesn’t work in Firefox but that probably has something to do with my profile :stuck_out_tongue:

Thanks for the help anyway.