OptOut-Text wird nicht angezeigt


#1

Habe das neueste Matomo installiert. Sowohl Matomo als auch alle meine Websites laufen mit let’s encrypt. Alles lief prima.
Seit wenigen Tagen bin ich mit meinen Joomla-Websites zu einem neuen Webhoster umgezogen. Die Matomo-Installation habe ich frisch vorgenommen unter Verlust der bisher gesammelten Matomo-Daten.
Matomo und das Tracking funktionieren zwar einwandfrei, aber der Opt-Out-Text wird nicht angezeigt. Über den von Matomo gezeigten Link ist der OptOut-Text aber erreichbar. Also liegt der Fehler bei der Art der Einbindung in meine Website.

Dort habe ich keinen iFrame benutzt, sondern ich rufe über die JCE-Mediabox eine Shadowbox auf, die sich über die Website legt. Der OptOut-Text wird dann in dieser Shadowbox angezeigt. Die Shadowbox ist technisch aber auch nix anderes, als ein iFrame.

In meiner htaccess habe ich (damals auf dem alten Hoster und jetzt auch) folgende Header gesetzt:

<IfModule mod_env.c>
Header set Content-Security-Policy "default-src 'self' 'unsafe-inline' https://matomo-installation"
Header set X-Content-Type-Options "nosniff"
Header set X-XSS-Protection "1; mode=block"
Header set X-Frame-Options "SAMEORIGIN"
Header set X-Robots-Tag "index, follow"
Header set X-Download-Options "noopen"
Header set X-Permitted-Cross-Domain-Policies "none"

Auch ein Versuch mit Auskommentieren der Sameorigin-Police oder der Content-Security-Police ändert sich nix.

Woran könnte es denn jetzt noch liegen?


(Lukas Winkler) #2

Hallo,

Falls Matomo und die Seite nicht von der selben Origin (also Domain und https/nicht-https) sind, wird ein sameorigin nicht funktionieren.


#3

Danke für deine Antwort. Aber ich schrieb doch, dass ich bereits versuchsweise Header set X-Frame-Options “SAMEORIGIN” auskommentiert hatte und das Problem blieb bestehen.
Zudem hatte die Installation mitsamt dieser htaccess schon mehrere Jahre bei dem anderen Webhoster funktioniert.

Genau deshalb frage ich ja hier.


(Lukas Winkler) #4

Hallo,

Kannst du die Browser-Konsole auf der Webseite öffnen? Dort sollte dann stehen, warum genau die Anfrage nicht funktioniert.


#5

Sorry aber wo ist die “Browserkonsole”?

Ich hab die jetzige Matomo-Installation nachträglich auf eine Sub-Domain einer der Websites gelegt, die analysiert werden soll und die Eintragungen in der config.ini.php entsprechend angepasst.
Resultat: Jetzt wird auf dieser einen Website der OptOut-Text angezeigt.

Aber was ist mit den anderen beiden Websites? Da bleibt der Fehler! Also muss in der htaccess von Matomo etwas drin stehen, das evtl. mit “same origin” die Einbindung verhindert.
Bisher (auf dem bisherigen Server) hatte ich fünf verschiedene Websites mit dieser Matomo-Installation analysiert ohne diese Probleme!

Dabei fällt mir auf, dass im Basisverzeichnis der Matomo-Installation keine htaccess liegt. Wo liegt denn eine, die evtl. aufgrund der same-origin-police hier so stört?

Ich bin doch sicher nicht der Einzige hier, der mit einer einzigen Matomo-Installation mehrere Websites unter verschiedenen Domains anaylsieren will???


#6

Sorry, ich hab den vermeintlichen Fehler gefunden!
Meinen Firefox-Browser habe ich mit Add-Ons bestmöglich abgesichert, z.B. auch durch uBlockOrigin, uMatrix, DecentralEyes usw.
uBlockOrigin blockt mir die Möglichkeit, den Link zum OptOut anzuklicken.

WEnn ich uBlock-Origin deaktiviere oder die Weiterleitung zum OPtOut-Link zulasse, wird der Text einwandfrei angezeigt.

Da aber immer mehr Menschen solche AddOns einsetzen, müsste ich eine Möglichkeit finden, wie dennoch die OptOut-Links funktionieren.
Vielleicht geht es, wenn der Link zum OptOut zunächst auf eine html-Seite auf der zu trackenden Website zeigt und diese per redirect (evtl. über htaccess?) auf den OPtOut-Text zeigt???


(Lukas Winkler) #7

Hallo,

In den Entwicklertools (du kommst mit der F12-Taste am schnellsten hin) des Browsers.

uBlockOrigin hat eine praktische Funktion, die auflistet, was genau weshalb blockiert wird:
image