Opt-out iFrame wird nicht angezeigt


#1

Hallo zusammen,

ich kämpfe gerade mit dem Problem, dass der iFrame in der Datenschutzerklärung nicht angezeigt wird - vielleicht habt ihr eine Idee?

<iframe frameborder="no" width="500px" height="250px" src="http://pwk.ciderkultur.de/pwk/index.php?module=CoreAdminHome&action=optOut&language=de"></iframe>

Der Code stammt von der IT-Recht-Kanzlei. Matomo liegt bei mir auf einem anderen Webspace als der Rest der Website.

Matomo selbst gibt mir folgenden Code vor:

<iframe
        style="border: 0; height: 200px; width: 600px;"
        src="http://pwk.ciderkultur.de/pwk/index.php?module=CoreAdminHome&action=optOut&language=de&backgroundColor=&fontColor=&fontSize=&fontFamily="
        >

Letzterer führt aber auch zu keinem Ergebnis. Ich kann dort Farben ändern, Schriftgröße anpassen etc. - am Code ändert sich aber nichts.

Hier noch der Link zur Seite (Punkt 7):
https://www.ciderkultur.de/datenschutz/


(Fabian Dellwing) #2

Ändere die src deines Iframes auf https und es funktioniert :wink:

Achja: frameboder="no" ist deprecated. Benutze also besser style="border: 0;"


#3

Das hat funktioniert, vielen Dank.

Ich weiß allerdings nicht, warum es geklappt hat. Matomo liegt ja auf einem Webspace, der an dieser Stelle noch keine SSL-Verschlüsselung aufweist.


(Fabian Dellwing) #4

https://pwk.ciderkultur.de/ hat ein valides SSL Zertifikat (Let’s Encrypt), sonst würde das ganze nicht funktionieren.

Dein Problem war, dass du auf einer SSL Seite aktiven Inhalt von einer nicht SSL Seite einbinden wolltest (also ein http Iframe auf einer https Seite). Dies ist schlicht und einfach nicht möglich und wird vom Browser blockiert.

Du musst dein Matomo in diesem Fall also zwingend via SSL einbinden. Für deinen Trackingcode hast du das auch gemacht gehabt, halt nur nicht für das Opt-Out Frame :wink:


#5

Hallo,

ich habe gerade den optOut iframe auf meiner Website eingefügt.
Da heißt es im Text: “Wenn Sie sich dagegen entscheiden möchten, klicken Sie den folgenden Link, um den Matomo-Deaktivierungs-Cookie in Ihrem Browser abzulegen.”

Einen Link kann man da ja aber gar nicht anklicken.
Sollte es nicht lieber heißen:“Entfernen Sie den Haken in der Checkbox, um den Matomo-Deaktivierungs-Cookie in Ihrem Browser abzulegen.” ?


(Lukas Winkler) #6

Hallo,

Du hast recht, das ist schlecht formuliert.

Überhaupt gehört der komplette Opt-Out-Text verbessert:

In diesem Fall scheint es aber an der Übersetzung zu liegen:

To make that choice, please click below to receive an opt-out cookie.


#7

Okay, na dann warten wir mal ab, ob sich da in den nächsten Tagen noch etwas ändern wird.


#8

Ich noch mal.
Mittlerweile ist fast eine Woche vergangen. Wird die Übersetzung noch vor dem 25. Mai, bevor die DSGVO in Kraft tritt, geändert werden?
Das wäre jedenfalls nett.