Oops… there was a problem during the request


#1

I recently upgraded to the latest version. Coincidentally, my bounce rate on my site jumped through the roof and all users leave after trying to load one page. Not sure if that is relate to what happend this morning…

So, this morning I try to open PIWIK and I get this on almost all my widgets:
“Oops… there was a problem during the request. Maybe the server had a temporary issue, or maybe you requested a report with too much data. Please try again. If this error occurs repeatedly please contact your Piwik administrator for assistance.”

I did a search and found something about removing …/Goals.php but that does not exisit.

No changes to server.
Please advise.


#2

When I click on my admin name in the upper right I get the following error message:

WARNING: /home/barplans/public_html/trx/plugins/PrivacyManager/Config.php(103): Warning - Illegal offset type - Piwik 2.12.1 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)


#3

My hosting support is saying that PIWIK is trying to to allocate way too much memory.

Their response:

Something doesn’t seem to be right with the piwik from what i can tell. It’s giving you a memory limit error indicating that the php script is trying to use more memory than you have it set to. Your error says "Allowed memory size of 134217728 bytes exhausted"
This is 128M defined by the /usr/local/lib/php.ini file
Now it says it tried to allocate 1836062721 bytes. This is 1751 MB or 1.7G That’s way too much memory for anything on the server to really request. Your server only has 8G of memory so it’s literally asking for about 25% of it for 1 process. You’ll want to look at perhaps updating or removing piwik and putting it back on if still needed.


#4

So, I reloaded all files using binary FTP and still no luck.
I was able to access the admin area, ran a systems check and it says Huzzah! No Problems.
However, the PHP version I am running is 5.3.29 and the system says >= 5.3.3? yet passes.

Funny, this latest upgrade ran for two days under 5.3.29 before crapping out.


#5

Maybe you have too much data to parse all at once?
Have you tried disabling “Allow Piwik archiving to trigger when reports are viewed from the browser”?