Ooops und " client denied by server configuration" Fehler bei frischem Piwi


#1

Hey Leute

Ich hab mir gestern auch mal Piwi auf meinem Server installiert (Root mit Debian und Apache). Es funktioniert eigentlich auch ganz gut, allerdings hab ich 1 Problem. Ich bekomme beim Seitenwechsel sehr oft diesen Fehler:

[size=small]Oops… während der Anfrage ist ein Problem aufgetreten. Möglicherweise war der Server temporär überlastet, oder eventuell haben Sie einen Bericht mit zu vielen Daten angefordert. Bitte noch einmal versuchen. Wenn dieser Fehler wiederholt auftritt kontaktieren Sie bitte Ihren Piwik Administrator, um Unterstützung zu erhalten.[/size]

In der Error Config vom Apache ist mir folgendes aufgefallen:
[Fri Mar 20 13:53:12 2015] [error] [client 192.168.1.3] client denied by server configuration: /var/www/seite/piwik/index.php, referer: http://www.seite.de/piwik/index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday

Ich gehe mal davon aus, dass es an meiner VHost liegt:


<VirtualHost *:80>
        ServerAdmin mail@seite.de
        ServerName www.seite.de
        DocumentRoot /var/www/seite
        <Directory />
                Options FollowSymLinks
                AllowOverride All
        </Directory>
        <Directory /var/www/seite>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
        <Directory /var/www/seite/piwik>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
                <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>
        ErrorLog /var/log/apache2/www.seite.de-error_log
        CustomLog /var/log/apache2/www.seite.de-access_log common
</VirtualHost>

Kann mir da ggf. einer bei helfen? :slight_smile:
Lg Ovi


#2

Ach ich habs… “mod-evasive” war dafür verantwortlich.