One click update doesn't work


#1

Hello,

Very recent install, this has happened for both the 3.5 and the 3.5.1 updates.

I’m getting the error:

Note: Matomo’s One Click update requires write-permissions to the Matomo folder and its contents.
Matomo is unable to overwrite your current installation. You can either fix the directory/file permissions, or download the package and install version 3.5.1 manually: chown -R www-data:www-data /usr/share/piwik
chmod -R 0755 /usr/share/piwik
After you execute these commands (or change permissions via your FTP software), refresh the page and you should be able to use the “Automatic Update” feature.

The permissions on the files and directories are correct however. Any ideas would be appreciated!


#2

Nevermind! After digging through the code I realize it was something about my particular system configuration.

Please close this!