Nothing is tracked from Firefox on Mac

Hi all,
I do not see any error in the Web Console, but, nothing is tracked when I am browsing from a Firefox browser, on a Mac. I do not have this issue when I am using the other browsers: Chrome, Opera, and Safari.
What is more interesting is that I do not have this problem when I am on Ubuntu.
Any idea what could be the source of this issue?

Thank you

Hi,

Can you check that you have not enabled DoNotTrack (which Matomo respects out of the box) or are using an ad-blocker that blocks the request?

Also check the browser console and network monitor to see if there are any errors or if the matomo.php request is going through.

Hi,

Thank you for answering so fast.
I set the “Tracking Protection” to off, but still no results.
Also, in the console, I do see a request to matomo.php file. The status code of that request is 200.

Hi,

If you want to be completly sure why the request is not stored, you can (temporarily!) enable this:
https://developer.matomo.org/api-reference/tracking-api#debugging-the-tracker

Then the matomo.php will respond with a very verbose log on how the request is handled.

Keep in mind that Tracking Protection is not the same as DoNotTrack:
https://support.mozilla.org/en-US/kb/how-do-i-turn-do-not-track-feature

I do get a response.
I have the impression that Matomo is tracking the events from the Firefox browser, but, it is not reporting them. Could that be a case?

Hi,

The response should explain if the data is stored and if not, why.

If the visits appear in the visitor log, then they were recorded.

Hi,

Can you please guide me? I have a lot of data and I do not know what I should be looking for.

Hi,

If you want to, you can send me a direct message with the matomo.php response.

Hi,

I found this
aborting due to processRequestParams method
But, what does it mean?

and this one:
Visitor excluded. [] {“class”:“CoreHome”,“request_id”:“d691b”}

The context of those lines would help me. Could you send me the whole output?

[2020-04-28 10:09:22] piwik.DEBUG: DoNotTrack header found! [] {“class”:“PrivacyManager”,“request_id”:“919ec”}

[2020-04-28 10:09:22] piwik.DEBUG: Visitor excluded. [] {“class”:“CoreHome”,“request_id”:“919ec”}

[2020-04-28 10:09:22] piwik.DEBUG: -> aborting due to processRequestParams method [] {“class”:“Piwik\Common”,“request_id”:“919ec”}

[2020-04-28 10:09:22] piwik.DEBUG: -> Scheduled tasks not triggered. [] {“class”:“Piwik\Common”,“request_id”:“919ec”}

Here we are: The reason has been found. Your browser sends a DNT: 1 header with every HTTP request which indicates Matomo, that you don’t want any data to be saved.

You can disable it as explained here:
https://support.mozilla.org/en-US/kb/how-do-i-turn-do-not-track-feature

This is off. Unless, I need to manually configure it

You can check in the header section of the matomo.php request if your browser is sending the DNT: 1 header.

grafik

I do see this. Any way for matomo to ignore it?

Hi,

Yes, you can configure in the Matomo admin settings to ignore it.

Just (as always) keep your local privacy laws in mind.

Hi,

Which setting is this?

Privacy -> Users Opt-Out

It is enabled. I think that it has to do with the cookies

That is the point: If this setting is enabled, then Matomo will ignore and not save and data from Browsers that have enabled the DoNotTrack setting (like your Firefox browser).