Nothing is registered


#1

We installed matomo yesterday on our new site and got the all clear from the system check up. No errors found.
We installed the tracking code using the plugin for Subrion CMS, and looking at the source code of the pages, the tracking code is there, in the right place, on all pages.
We then asked a number of friends from all over the world to visit the site, and just have a look around, proof read articles etc. Expecting these visits to show on the dashboard.
Now, 24 hours later, it still tells us that there are no visits and shows no visits.

Has anybody any idea what could be causing this. It is vital that we get this going, soon…
Thanks
Ian


(Lukas Winkler) #2

Hi @Yanis ,

It’s most probable that the tracking script is unable to send the data to Matomo.

So can you open your website in a browser, open the browsers developer tools (F12) and check for error in the Javascript console or failed requests on the network tab.


#3

Thank you. Just did this, and the developer tools (google) tell me ::Failed to load resource: the server responded with a status of 403 (Forbidden).
so, where do we go from here?


(Lukas Winkler) #4

This means that your webserver doesn’t allow the browser to access the file (either piwik.js or piwik.php).

Check if the path it is requesting is correctly, and if your webserver is configured correctly. (The apache/nginx log should show why a 403 is returned)


#5

Right, this is way over my head…


(Lukas Winkler) #6

If you want to, you can post (or send me a message with) the URL to your website. While I can’t tell you how to fix the configuration, it is still possible, that this is just a simple typo.


#7

I have disabled the Subrion plugin and pasted the tracking code directly into the into the layout template, just before the closing tag. No good. So where do I go from here, or do I uninstall and forget about it?


(Lukas Winkler) #8

Hi,

I don’t really know how I can help finding out, why your server returns 403.

One more thing: Are you using mod_security?

Matomo doesn’t support it and you need to disable it for this host to work.
https://matomo.org/faq/troubleshooting/faq_100/


#9

We took another look at all of this, and got it going. The mod-security tip did the trick, thank you. Now it logs visits, pages, etc. as it should. However… locations are not correct. It would seem that, despite having the necessary database installed as well as the IP2location plugin, all our users seem to be located in San Jose, USA, and all have the same IP address… We have checked the set-up for geolocation, and it is as it should be…


#10

f you are seeing the same IP for everyone it is likely there is a reverse proxy fronting your Matomo server. Trying this may work. How do I configure Piwik when the server is installed behind a proxy? - Analytics Platform - Matomo