Not visible data after upgrade from 2.2.2 to 2.3.0

Hello all,

Today I’ve upgraded my Piwik from 2.2.2 to 2.3.0 using “Update Automatically” method. The upgrade process
was successful, but something has been broken, because I couldn’t see any data. Please take a look at the attachment
with a screenshot. There are PHP syntax error and the missing files.

Can you have any idea what a reason of the issue could be?

Best regards,

PS. I’ve downgraded my Piwik to 2.2.2, because I need a well working production server.

I’m not sure what is the problem. Did you customise some theme files (CSS or Less files?).

Hi Matt,

Thanks for your reply! No, I didn’t touch any files. I use upstream Piwik with only customised configuration, of course.

Are you using Apache web server? If so, please try to upgrade to 2.4.0 where we have fixed couple issues with apache. I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo

if you have same problem with 2.4.0 beta, can you check your server error log ofr a message?

Yes, I use Apache server for my Piwik. Do you think that version 2.3.0 has some Apache related errors? I’ve been using Piwik for about 2 years and done a lot of upgrades, but I don’t remember such issues.

Is it safe to upgrade Piwik directly from 2.2.2 to 2.4.0? Or should I upgrade to 2.3.0 and then to 2.4.0?

I’ve got the same problem after upgrading to piwik 2.3. My system is a debian wheezy with apache 2.2.22-13+deb7u1. When I upgrade to piwik-2.4.0-b3 the problem persists with no errors in the apache-log, but an useable interface (logout link not clickable for example).

After little more trial’n’error I found a solution:

  1. backup your config.ini.php
  2. remove complete piwik folder
  3. get (version 2.3) and unpack it
  4. place your backed up config.ini.php into the config folder
  5. navigate to piwik as admin and you’ll maybe see some outdated plugins, which you have to reinstall over the marketplace …

did this work for you?

Hi borkenkaefer,

Thanks for your feedback! What about upgrading a database schema?

Piwik takes care about upgrading the database schema upon the first login on the new installation.

Thank you for the explanation! I’ll try your way tomorrow :slight_smile:

It is safe to update to the 2.4.0 beta version (it works better than 2.3.0 stable)

It seems that I have too old version of PHP in order to install Composer… Well, it’s probably a good reason to upgrade my machine finally :slight_smile:

# php composer.phar install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for symfony/console v2.4.4 -> satisfiable by symfony/console[v2.4.4].
    - symfony/console v2.4.4 requires php >=5.3.3 -> no matching package found.
  Problem 2
    - Installation request for phpunit/php-code-coverage 2.0.6 -> satisfiable by phpunit/php-code-coverage[2.0.6].
    - phpunit/php-code-coverage 2.0.6 requires php >=5.3.3 -> no matching package found.
  Problem 3
    - Installation request for phpunit/php-file-iterator 1.3.4 -> satisfiable by phpunit/php-file-iterator[1.3.4].
    - phpunit/php-file-iterator 1.3.4 requires php >=5.3.3 -> no matching package found.
  Problem 4
    - Installation request for phpunit/php-text-template 1.2.0 -> satisfiable by phpunit/php-text-template[1.2.0].
    - phpunit/php-text-template 1.2.0 requires php >=5.3.3 -> no matching package found.
  Problem 5
    - Installation request for phpunit/php-timer 1.0.5 -> satisfiable by phpunit/php-timer[1.0.5].
    - phpunit/php-timer 1.0.5 requires php >=5.3.3 -> no matching package found.
  Problem 6
    - Installation request for phpunit/php-token-stream 1.2.2 -> satisfiable by phpunit/php-token-stream[1.2.2].
    - phpunit/php-token-stream 1.2.2 requires php >=5.3.3 -> no matching package found.
  Problem 7
    - Installation request for phpunit/phpunit 4.1.0 -> satisfiable by phpunit/phpunit[4.1.0].
    - phpunit/phpunit 4.1.0 requires php >=5.3.3 -> no matching package found.
  Problem 8
    - Installation request for phpunit/phpunit-mock-objects 2.1.0 -> satisfiable by phpunit/phpunit-mock-objects[2.1.0].
    - phpunit/phpunit-mock-objects 2.1.0 requires php >=5.3.3 -> no matching package found.
  Problem 9
    - Installation request for sebastian/comparator 1.0.0 -> satisfiable by sebastian/comparator[1.0.0].
    - sebastian/comparator 1.0.0 requires php >=5.3.3 -> no matching package found.
  Problem 10
    - Installation request for sebastian/diff 1.1.0 -> satisfiable by sebastian/diff[1.1.0].
    - sebastian/diff 1.1.0 requires php >=5.3.3 -> no matching package found.
  Problem 11
    - Installation request for sebastian/environment 1.0.0 -> satisfiable by sebastian/environment[1.0.0].
    - sebastian/environment 1.0.0 requires php >=5.3.3 -> no matching package found.
  Problem 12
    - Installation request for sebastian/exporter 1.0.1 -> satisfiable by sebastian/exporter[1.0.1].
    - sebastian/exporter 1.0.1 requires php >=5.3.3 -> no matching package found.
  Problem 13
    - Installation request for symfony/yaml v2.4.4 -> satisfiable by symfony/yaml[v2.4.4].
    - symfony/yaml v2.4.4 requires php >=5.3.3 -> no matching package found.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <> for more details.

Read <> for further common problems.

I’ve upgraded Ubuntu distro on my machine and installed Composer successfully. Now Piwik 2.4.0-b3 works fine for me. Thanks for your help!