Not getting reports in email after upgrdaing from 1.12 to 2.0.2


#1

Any thoughts about it. After upgrading to 2.02 , not getting the reports in email schedule as daily.


(Matthieu Aubry) #2

Have you setup this: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

If so did you get any email from the cron that could show an error? any error in your server error file?


#3

i was not using Cron Job. I just schedule it in email setting and just using php mail function.


(Jeff) #4

We’re having a similar issue. Before we applied the upgrade to 2.02, reports were emailed as to us every week. After the upgrade, they stopped. If I go to the “Manage Email Reports” and click “Send Report now” it is delivered within a minute or two. I tried creating a new daily report, and that one doesn’t get sent either. It acts as if there just isn’t a schedule.

We’re running on a Windows 2012 server; I’m not seeing any errors in the event logs, and I’m not familiar with PHP or My SQL, so I don’t know where else I should be looking to find any errors.

Any help or advice is appreciated. Thanks.


(Matthieu Aubry) #5

When you have setup the “automated task” as explained in: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

On linux if setup as this, it will email in case there is an error.

Maybe this change would also help you, can you try it: Refs #4404 Error when downloading pdf-report · matomo-org/matomo@566c63a · GitHub


(Jeff) #6

Thanks for your response.

I tried making the change to those 2 pages and it made no difference–still didn’t get the daily report I was expecting.

On our test server, I tried to setup the automated task, but I get a certificate error: “unable to get local issuer certificate”

I’ve not had much time to try to trouble shoot this yet, but it is a valid certificate we have on the server, and the site comes up with out any issues.


(Matthieu Aubry) #7

maybe you can work around this error by adding a parameter to the archive.php script in cron:


	--accept-invalid-ssl-certificate
			It is _NOT_ recommended to use this argument. Instead, you should use a valid SSL certificate!
			It can be useful if you specified --url=https://... or if you are using Piwik with force_ssl=1


(Jeff) #8

Thanks, using that parameter worked. Every time the archive script ran, reported “no error” and under SCHEDULED TASKS, it says “No task to run”. I’ve scheduled it to run once an hour every day.


#9

Hi,

this morning the (weekly) reports were delivered automatically.

It seems to be so, that Piwik 2.x needs an archive cronjob.
Without this cronjob, the reports were not delivered.

Now, it works for me with an archive cronjob.


(Jeff) #10

It is now fully working on our test environment when the scheduled job was set up. I will be setting up the job on our production server this week, and I’ll know next Monday for sure, but I agree that the archive job is the key.

Matt, thanks for your help with this.


(Matthieu Aubry) #11

you’re welcome! glad Piwik works for you


(Jeff) #12

Trying to set up the archive job on our production servers, I’m getting an error when I run the script. I get anywhere from 3 to 15 of the following types of errors:


ERROR: Got invalid response from API request: https://***/piwik/index.php?module=API&method=VisitsSummary.getVisits&idSite=1&period=week&date=last81...  The response was empty. This usually means a server error. This solution to this error is generally to increase the value of 'memory_limit' in your php.ini file. Please check your Web server Error Log file for more details.

The tasks that error all do so after about 1 second, but the ones that succeed can take up to 6 seconds, so it doesn’t appear to me to be strictly a time out issue, but I’m not that familiar with the PHP. If I run that url in the browser window, it takes only a few seconds, however running the “year” one takes nearly 2 minutes, when I run it in a browser window, and I see no error, just a string that looks like it is probably json.

There are no errors in the PHP54_errors.log file – the last entry was 2 weeks ago. I don’t know if it for some reason stopped logging there after the 9th and there are still errors that just aren’t being logged.

I tried increasing the memory anyway to 1024M (from the 128M) and verified with phpinfo(); but it didn’t make a difference. Our main site gets about 15K page hits a day, but the other sites we’re tracking get less than 300 a day, and all get these errors.

Is there any other setting or log I should look at to see why this might be happening? When I searched, I didn’t find any reference to this error with nothing in the server error logs.

I’ve scheduled it to run tonight anyway, hoping that at least we’ll get the scheduled reports emailed as they should.


(Matthieu Aubry) #13

There should be an error in the server error log file, if correctly configured?


(Jeff) #14

The good news is that the original issue is resolved - turning in on the scheduled job made the scheduled reports work correctly in production, even with these other errors.

As for everything else, I’ve double checked the location of the error logs and that logging is turned on. I wrote a test message to the error log (using error_log(“Test Error Message”):wink: and I verified that it was written to the log file.

At this point, since all seems to be working despite these issues, I’m going to let sleeping dogs lie, for the time being. Hopefully I’ll be able to get back to this in a little while and look it again, maybe upgrade to php 5.5

Thanks.


(Matthieu Aubry) #15

I believe you were (before setting up cron) experiencing a real bug, I created ticket at Regressed: Scheduled reports should be sent automatically by webcron, when cron is not setup · Issue #4612 · matomo-org/matomo · GitHub


#16

Hi,

i have same issue after upgrading from 1.9 to 2.0.2. with PHP 5.3.2.
Also affected is auto update of geoIP Databases. With webcron archive.php the archive tasks and geoIP update are done, but report emails were not automatically sent. I am able to send the email reports manually.
I’m looking forward for resolve this problem in Regressed: Scheduled reports should be sent automatically by webcron, when cron is not setup · Issue #4612 · matomo-org/matomo · GitHub

Thanks


#17

Hi,

i have same problem with 2.0.3 and PHP 5.3.2
Also affected is auto update geoIP DB. Run the webcron archive.php all archive tasks and geoIP update are done, but emails were not sent automatically. Manually I can send reports.

I’m looking forward for solution for ticket #4612

Thanks


#18

since it’s sometimes not only an email report problem I have opened a global ticket for not running tasks:
http://forum.piwik.org/read.php?2,111305


(Matthieu Aubry) #19

Please update to latest piwik beta as we have fixed this bug!


#20

updated to B11 yesterday but
sorry looks still the same: no new tasks :frowning: