No visitor stats showing up


(Landscape Routes) #1

Hello,

I am using the Piwiki/Matomo wordpress plugin for my site https://landscape-routes.com
The Matomo instance is running in self-hosted in the same domain and I used the authentication token provided in Matomo API settings section.

I have started Matomo already for 4 hours and attempted to visit the site from several laptops, but the Matomo dashboard does not indicate any visit or stats.

I can see that the javascript code exists in every site pages. and the token is correct. there are no errors of tracking.

Any ideas of what can be going wrong? e.g. does matomo takes a full day before showing any stats?

thanks.

/Daniel


(Fabian Dellwing) #2

Hi,

as far as I can see, tracking is setup correctly. :+1:

For further investigation see this quote:

Do you see visits in the live visitor log?

No? Then your website is not sending data to Matomo anymore. Check for errors in the browser console, when you open your website.

Yes? Then visits are recorded properly, but reports are not generated, so please check if cron is set up and running successfully or browser archiving is enabled

If the live log contains data and archiving is setup correctly, check if the chosen date is today.


(Landscape Routes) #3

Thanks for the tips.

I did not see any visits in the visitor log. Then the errors on the browser do not seem to be related to matomo but to google fonts (unrelated) and to CloudFlare (possibly related):

Request to access cookie or storage on “https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700&subset=latin-ext” was blocked because we are blocking all third-party storage access requests and content blocking is enabled.

Request to access cookie or storage on “https://ajax.cloudflare.com/cdn-cgi/scripts/a2bd7673/cloudflare-static/rocket-loader.min.js” was blocked because we are blocking all third-party storage access requests and content blocking is enabled.

I am using Firefox browser that blocks third-party cookies. And I have tried with a different browser without cookie restriction. I have seen one visit from such browser (same computer as the previous attempts).

Could it be that the CloudFlare blocked service is also blocking Matomo?
Or does the Matomo only know the visits from browsers that allow 3rd party cookies? It should detect that there is a visit even though it cannot save a cookie on the person browser.