No graphs since 2.0


#1

Hi,

since I upgraded from Piwik 1.12 to Piwik 2.0, the software is very useless to me. At first, I didn’t even have a gadget. Then, I added this line to my config file which prevents Piwik from making one huge JS file rather than many little files. But I still do not have any graphs. It looks like the picture in the attachment. The JS error console says there’s something wrong.

I already re-uploaded (well actually extracted the latest.zip archive on the server), emptied the tmp folder several times but nothing helps. Using PHP 5.4 from dotdeb.org and other than that stock Debian 6.x (up to date of course).

Looks like piwik is still logging and the archive.sh script is still working. All folders have chmod 777, so it’s not a permission problem.

So what’s wrong?


#2

did you check memory settings in php.ini? at least 125 or 256 megs to try.

try deleting abd readding the widgets of your dashboard does that help?


#3

Memory Limit is at 512M and I can’t really see how a JS error could be fixed with more memory? Deleting widgets does not help either.


#4

if you allow the one big giant js file does it work at least?

can you temporarily turn off plugins to see if can eliminate the error?


(Matthieu Aubry) #5

Thanks for the report! I also tried another fix: Try require.js first to prevent js error when loaded after first users? · matomo-org/matomo@0bcd03b · GitHub

Maybe this will help this particular. so please update to 2.0.3-beta4 and then if you still have a problem, delete piwik/tmp/* files. does it help?


#6

@lesjokolat
If I allow Piwik to merge assets, I have no widgets at all, see first attachment.

@matt
Thanks for your reply. I upgraded to the latest beta and one JS error seems to be fixed but the rest remains (see attachment 2). I did empty the tmp folder.


#7

can you change browser to see if browser is the issue?


(Matthieu Aubry) #8

With “Merged” enabled, when you click on the link “getJS” in the console at the bottom, do you see the error that explain Piwik couldn’t merge JS?


#9

@lesjokolat
Firefox does exactly the same.

@matt
When I click the URI in the last line, it jumps to some JS code and highlights “e.defaultPrevented||e.returnValue===!1” - see attachment.


#10

Just to keep you guys updated: Upgraded to Piwik 2.0.3 and still no graphs.


#11

I upgraded to 2.1 RC9 and the graphs are back. Just sayin’. Thanks.