No Ecommerce/WooCommerce Data in Matomo Wordpress Plugin

Hi, Matomo is not collecting/displaying any WooCommerce Data - everything else seems to be tracked correctly.
I’m using a wordpress plugin (Borlabs Cookie), that adds the Matomo Tracking Code (see below).
The “add tracking code” option in the matomo plugin is disabled.

Tracking Code added by the plugin Borlabs Cookie:

<!-- Matomo -->
<script type="text/javascript">
var _paq = window._paq || [];
/* tracker methods like "setCustomDimension" should be called before "trackPageView" */
_paq.push(['trackPageView']);
_paq.push(['enableLinkTracking']);
(function() {
var u="%%matomoUrl%%";
_paq.push(['setTrackerUrl', u+'matomo.php']);
_paq.push(['setSiteId', '%%matomoSiteId%%']);
var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
})();
</script>
<!-- End Matomo Code -->

Under diagnostics the only issue (yellow) is this (location reporting is working):
“A proxy header is set which means you maybe need to configure a proxy header in the Advanced settings to make location reporting work. If the location in your reports is detected correctly, you can ignore this warning. Learn more: https://matomo.org/faq/wordpress/how-do-i-fix-the-proxy-header-warning-in-the-matomo-for-wordpress-system-report/

Hi @gavran

Thanks for creating a new topic.
Your problem looks related to an open issue we have:

The ecommerce data are not tracked if the add tracking code option is set to disabled.
We are working on it.
Please subscribe to the github issue to get the updates.
Kind regards

Matthieu

Hi @Matthieu_Mary , sadly the issue was not fixed with the most recent Matomo plugin update.
What is the best way to use the standard tracking mode while preventing tracking until the visitor opts in?

hi @gavran

For the tracking of your ecommerce data you could try to switch to manually mode and remove the tracking code. It would track only the ecommerce data.

To track only after an opt in from your visitor, you should use the tracking consent approach.
https://developer.matomo.org/guides/tracking-consent
The plugin allow you to specify the tracking consent option.

Kind regards

Mat