No Data


#1

Hi,
Its been about 4 years since I last used piwik! But here I am again now that my hosting company have caught up with the rest of the world.

I am having that age old problem: no data being recorded. I’ve spent hours going through the FAQ and other posts on this forum, but still can’t get it to work.

Here is the URL: www.echocolatebar.co.uk

As far as I can tell, the javascript code is correct. I also notice that data is not being logged into the mysql tables.

someone please help! it’s driving me crazy!


(Matthieu Aubry) #2

The page doesnt contain the Piwik code, so it will definitely not track anything…


#3

I’ve since removed the code and uninstalled. I’m going to try a complete fresh re-install (again) and see if that makes a difference.


#4

OK - I’ve reinstalled a freshly downloaded version, and a brand new mysql database.
I’ve gone through all the troubleshooting tips one by one and checked everything it could be.
I’ve also contacted my host (1and1) who were as useful as a chocolate teapot.

www.echocolatebar.co.uk - tracking code is visible and doublechecked against the standard in your FAQ. I am not getting any visits logged in the DB and there are no error messages in my error log.

Is there anything else you can suggest that I can try to get this working?


(Matthieu Aubry) #5

There is a conflict with one of the Javascript library you use. Somehow the piwik document.write is outputting a message in Firebug console instead of actually including piwik javascript file.

I think the solution is that you implement the change proposed in Test new snippet without document.write on various browsers + update all docs · Issue #2517 · matomo-org/matomo · GitHub

Or disable your other javascript libraries since one of them I think is causing the issue

btw your wp-slimstats returns error 404


#6

That’s sorted it, thank you Matt.

I’m not a coder so I don’t really understand what the problem was, but I’ve edited the tracking code as directed and it works perfectly now.

Many thanks.

P.S. slimstats is now gone :wink: