No Data Message


#1

Hey,

I just installed Piwik, and can’t seem to get it working. I’ve followed the FAQ and did the troubleshooting for why it wouldn’t be working, but it still isn’t working.

I’m thinking it may be because of the way I rewrite my urls for the site, but I’m not entirely sure.

The site is NeilHanlon.com.

I rewrite the URLs into what looks like directories under public_html. (ie. Neil Hanlon refers to Neil Hanlon, Neil Hanlon Contact – Neil Hanlon refers to neilhanlon.com/contact.php, etc.)

I just use MultiViews to do this.

http://httpd.apache.org/docs/current/content-negotiation.html

Any tips would be helpful.


#2

Anyone? Sorry to bump it, but I’m looking to get this working, and if I can’t get it working, I’ll just switch and use something else… I hate that a lot of good, open source stuff isn’t really supported…


(Matthieu Aubry) #3

Do you have logs in your DB? What is your website url? check Troubleshooting - Analytics Platform - Matomo


#4

As I said, I followed the troubleshooting steps. So no, there aren’t logs.

Also, I linked to my site in the original post. >.>


(vipsoft) #5

You split the string within the document.write() across two lines. (Yes, hard to tell with the spaces and single/double quotes.)


#6

Fixed the problem.

Along with your fix for document write (Which I’m pretty sure doesn’t matter because javascript isn’t linearly interpretted), the script was using HTTPS instead of HTTP.

Note to the developers: A lot of people don’t just have SSL Certificates laying around that they can use. Make it use the standard protocol by default, not the secure one.


(vipsoft) #7

In this case, the document.write does matter because the string contains javascript, so it must be treated as a literal string. Javascript doesn’t allow literal strings to span multiple lines.

The document.protocol check is to avoid the secure “page contains non-secure content” warning. If your host doesn’t have proper ssl certs, you can change the tracking code to always use http, but keep in mind that some users (depending on their browser settings) may get a popup; if they choose “no”, piwik.js won’t be loaded, and you won’t track that visit.


#8

Ah. I see. I’ve just run a quick test, and it does look like the document.write was the culprit and not the https… I blame nano…

Thanks!