No data if I active Auto Archiving / Database Size


#1

Hi,

I have Autoarchiving with Powershell-Script enabled. The problem is, that when i disable the archiving via browser feature, then I cannot see any visits in the webgui. Only if it is set to “Yes”, I can see them. What is wrong here?

I have now updated to 1.2, before to 1.2r5 but nothing helped out.
Another Quesions:
I have the installation now for ~5 weeks running and piwik waste 752 MB of space just for about 200 visitors in Total. Isn’t this extremely big? What is, if I rollout the site to my productive Servers. Do I need my own 20 TB SAN only for Website Monitoring?

rgds.
mstenz


(vipsoft) #2

Take a look at the server error log to find some evidence of why the powershell script isn’t running to completion.

The database size issue appears to be a side-effect of the first problem. The archiving process inserts temporary rows until the period has been successfully archived, at which point those temporary rows are deleted.


#3

thanks for your reply. But unfortenetly the archiving runs without any error. I have also no entrys in the error.log file.
Also every execution of archiving give back the correct values in the command console window, but i have checked what happens when i execute the same command in the browser from my client:
there are no visits recognized. Why is a difference in callling from cli and browser and why are the visits not really counted also when in CLI i can see them.

BYou are right in the growth of the tables. every archiving round it gets about 3MB more in space.

What I can do now?


(Matthieu Aubry) #4

Did you run archiving for the year ? it should run for the month and all days, then delete temporary archives. Otherwise, try re-installing from scratch?


(vipsoft) #5

php via cli vs the web browser may use separate php.ini files. check the memory_limit.


#6

[quote=matt]
Did you run archiving for the year ? it should run for the month and all days, then delete temporary archives. Otherwise, try re-installing from scratch?[/quote]
I run the complete powershellscript which archives 7 sites with day, week and year. and deleted the archives. Then run the archiving again. Results into the same issue. Reinstallation is not the best way i think.

php via cli vs the web browser may use separate php.ini files. check the memory_limit.

Memory_lmit was at 128MB, now at 512MB. My Browser and command line use defenitively the same php.ini
When the archiver process site 7 (with 90% of the hits) in year mode php.exe uses ~ 27MB memory maximum.

I can’t understand whats the difference between archiving with powershell and when i check “yes” in the gui. aren’t there called the same functions? Also there are no errors raised. Is there a debugging option where I can make a special logfile?


#7

push forward


(Matthieu Aubry) #8

Are you saying that requesting data for the ‘year’ works, for all websites, via the UI but does fail via the command line?

Appart from what has already been suggested by vipsoft I don’t see how this could happen


#9

[quote=matt]
Are you saying that requesting data for the ‘year’ works, for all websites, via the UI but does fail via the command line?

Appart from what has already been suggested by vipsoft I don’t see how this could happen[/quote]
Yes. when I put the option to “yes” in the UI. I can see data on the interface. But the DB size don’t gets smaller.

Is there any debugging option I can set to see why the archiving process will not get finished when use the powershell script? Becaus the structure of code is very complex I can’t figure out since now how the archiving is working (didn’t find out which class is loading)


(Matthieu Aubry) #10

What is the ouput when you run the powershell script?


#11

I have 7 sites. here is the output of site 7 (that one with the most hits) - all other sites run like the same (no errors)

Archiving period = day for idsite = 7…

<?xml version="1.0" encoding="utf-8" ?> 2 10 7 4 12 12 9 15 11 14 13 11 11 3 6 5 12 11 4 7 8 Archiving period = week for idsite = 7... <?xml version="1.0" encoding="utf-8" ?> 2 69 69 47 Archiving period = year for idsite = 7... <?xml version="1.0" encoding="utf-8" ?> 187 Archiving for idsite = 7 done! Piwik archiving finished. Starting Scheduled tasks...

No data available
Finished Scheduled tasks.


(Matthieu Aubry) #12

so… it is working, what’s the problem again?


#13

[quote=matt]
so… it is working, what’s the problem again?[/quote]

it don’t free the database and don’t show anything on the UI without enabline “yes” in the UI settings.


#14

I have now updated to 1.2.1, but there is the same issue.
Currently my database is 1,5 GB in size.
What can we do now?