"No data has been recorded yet"

I remember when it was just Piwik, it’s been a while…

So I have a bunch of WordPress sites, let’s say 10.

I have another site just for administrating my sites. Let’s say that admin domain is called whatever dot com

I use wp.whatever.com for infinitewp management.
an.whatever.com I installed Piwik/Matomo. (an = ANalytics)
Each of the 10 WordPress installations, I installed the WP-Piwik WordPress plugin.

I went to the analytics subdomain, logged in, clicked on Administration on the top right side, then the page that loaded I clicked on the left side bar API. Then under User authentication I copied the token to the first domain’s WP-Piwik settings.

On the Analytics subdomain, no data has been recorded, am I doing something wrong or it takes time for information to be recorded? I only have one site so far.

On Piwik mode, it is at: Self-hosted (HTTP API, default)

I am brand new to Piwik/Matomo. I tried piwik many years ago but went back to Google Analytics, now I left GA and I am trying to use Piwik/Matomo.

None of the WordPress sites are on whatever


Hi @miroslavglavic,

first of all, did you enable to add the tracking code to your site? Is the code shown as expected in WP-Matomo’s settings (tracking tab)? And, of course, does it appear in your site’s source code? Also keep in mind that WP-Matomo is able to filter logged in users (e.g., to avoid to track you as an admin).

Best regards

1 Like

Hi @WP_PiwikDev,

I am facing a similar issue. I have implemented the Matomo to my Sharepoint site following instruction from the below link’s 3rd point and getting " No data has been recorded yet, get set up" I have copied the JS code to the seattle.master of my site but I am not able to see the change in the developer’s tool. Do you have any idea why I can see the change in developer’s tool or how the get the data on Matomo Dashboard for my site

This thread is about the WordPress integration of Matomo, not about Sharepoint. I never integrated Matomo into Sharepoint and this is a very different topic, so you should start your own thread.