No Campaign Records but Entry Records in TYPO3 site


#1

Dear Forum,

I have a problem using Piwik Campaigns in my TYPO3 installation: I made a qr-code with the following url:
http://www.domain.de/index.php?pk_campaign=QRcode-2014&pk_kwd=CityCard-rhein-neckar

Some months ago, a test with this url succeeded, a campaign was visible in Piwik. After some Piwik-updates now it does not work anymore. Piwik logs the page impressions as index.php, but there is no campaign record.

The URL www. redirects to mobile. when a mobile device is used. The redirect does not preserve url-params. But I also testet the campaign-param with both (www and mobil) directly. No effort. No campaigns under www nor under mobil stats.

I got the apache.logs from the hoster of our managed server, but there are no entries on this case ?:expressionless:

Does anyone have a solution or an idea the analyse the problem further?

Thanks
Martin


#2

Hi Martin,

did you find a solution? I face the same issue.

Which TYPO3 version are you running? Here the issue occurs using TYPO3 6.2.

I tested TYPO3 4.5 too. There the campaign tracking works with

  • both syntax (hash and url-parameter).
  • realURL - enabled
  • realURL - disabled

Best regards,
Marcus


(Matthieu Aubry) #3

Hi there,

The URL www. redirects to mobile. when a mobile device is used. The redirect does not preserve url-params. But I also testet the campaign-param with both (www and mobil) directly. No effort. No campaigns under www nor under mobil stats.

This is the problem, the redirect should keep the URL parameters. Then campaign tracking should work