No Analytics or Logs Being Generated (v2.4.0)


#1

I’ve read Troubleshooting - Analytics Platform - Matomo.

I have Piwik 2.4.0 installed on a Debian 7 server with Nginx and MySQL.

I have tried disabling SSL on the site being tracked (though the Piwik domain and the target domain have valid certificates, and resources such as the javascript and image load just fine with either protocol). I also made a simple test page: http://tohuw.net/piwiktest.html

I am certain I have the correct tracking code; I verified by re-copying from the settings in the web console.

I am looking for any reports from “Today” or otherwise, and none display. The table piwik_log_visit remains empty, but other tables for Piwik configuration, etc. are appropriately populated.

I ensured index.php and piwik.php consistently and correctly load. Disabling Javascript does result in the image loading, but still no stats are logged.

I have no bootstrap.php and no particularly strange settings that I can think of.

Nginx logs do not reveal anything anomalous that I can determine.

My Nginx configuration: http://paste2.org/PNyOUjHs

Any ideas?


#2

I should also mention I ensured none of the clients blocked Piwik via extensions or the “Do not track” option. I tested with multiple clients, none of which had the blocking cookie installed.


(Matthieu Aubry) #3

See: Piwik doesn't track any visits and pages, and shows "There is no data for this report" in all reports. - Analytics Platform - Matomo

If this doesn’t help then you can debug the tracking code: Tracking HTTP API: API Reference - Matomo Analytics (formerly Piwik Analytics) - Developer Docs - v3


#4

I have gone through the entire FAQ you linked, and I do not see anything errant in my configuration. I’ve enabled debug in the tracker section of config.ini.php, but I do not see anything unexpected in the requests. I’ll leave this enabled in case someone has a moment to put another set of eyes on it: https://tohuw.net/piwiktest.html


(Matthieu Aubry) #5

debugging is not enabled on this piwik server?


#6

I put this in config.ini.php (as it happens, it’s the only thing in there):


[Tracker]
debug = 1


#7

My question about enabling debug stands, but it seems to work now. It never generates stats for me, and I have piwik unblocked in ghostery and don’t have the cookie set from PIwik settings, but I can probably figure this out later. The other clients I tested didn’t work, but that was a few revisions of settings ago, so there’s that.