New User of Piwik... First Issues... Characters Are Shown As ASCII... Missing Data, etc

Good day everyone, I’m a new user of Piwik and first of all I want to say thanks for creating this open software for those who are tired of GA.

I’ve been playing with Piwik during the last 2 hours and the first issue I just found is that special characters in page titles names are being shown in their ASCII value.

For example, if titles of my website have the dollar sign “$” in the visitor log and wherever page titles are displayed, it is shown as “%24”.

“|” as “%7C”, “,” as “%2C”, etc.

Also, all visits are being shown as a “Direct Entry”. There must be something wrong here.

And finally, in the Visitor Log page, Actions column, below the title name, all URLs have “Page URL not defined”, there must be something wrong here too.

After I finish the installation successfully the only setting I’ve changed or moved, was the “cron job” which I set it up through cpanel and changed “Allow Piwik archiving to trigger when reports are viewed from the browser” from “yes” to “no”.

Any idea what’s going with these issues or how to solve them?

Thanks!

Also, all visits are being shown as a “Direct Entry”. There must be something wrong here.

http://piwik.org/faq/troubleshooting/#faq_51

And finally, in the Visitor Log page, Actions column, below the title name, all URLs have “Page URL not defined”, there must be something wrong here too.

Maybe you have a redirect setup to your piwik, eg. SSL -> HTTP or similar, that changes URLs from tracking etc. causing issues