New tracker code does not work

After Updating to Piwik 1.11.1 I have changed the tracking code in my websites. Basically I have copy and past the code from the user settings in all of my documents.
No visitor is recordet. The position is correct as the old code is working correctly.
If the new code is installed in pages on the same server like piwik itself it works correctly.
Firebug gives the below warnings:
TypeError: function g does not always return a value
[Bei diesem Fehler anhalten]

…n"null"}j+=b;o=[];if(Object.prototype.toString.apply®==="[object Array]"){f=r…

piwik.js (Zeile 11)

TypeError: function K does not always return a value
[Bei diesem Fehler anhalten]

…}else{O.apply(B,N)}}}function K(O,N,M,i){if(O.addEventListener){O.addEventListen…

piwik.js (Zeile 13, Spalte 60)

TypeError: function a does not always return a value
[Bei diesem Fehler anhalten]

…a(h){try{return eval(“piwik_”+h)}catch(i){}return}var c,e=Piwik.getTracker(d,f)

piwik.js (Zeile 29, Spalte 60)

But I am getting similar warnings for the old code.

Has somebody any idea, what could be the problem? No additional character have been added as I used Notepad to change the web pages.

Link to the page where it’s installed? The new code is working - so there must be some error on your page.

Not working at: - is for sale (Arnolds Deal)

working and installed at: Fehler

Does anybody has an idea why the problem shows up or is it just a bug?

Is the URL below exactly the same as before or is it new?

Could you change it to:

and try then?

The URL is correct. The minus should not be the problem as I have tried it also with a test.php with the same result.


I did what you told. Removed the minus in the file name and put in the piwik code again. And it worked (at least I thought so).
But than I realized that I forgot to put the noscript tags around the image tracker.
After I corrected it - the same problem, no tracking!

That means in generall piwik works. There must be something wrong with the tracking code?

Do you have browser archiving turned on? If not please setup cron archiving. The tracking code definitely works as it sends the tracking information to piwik.php.

Browser archiving is on.

The old code still works.

If you have checked the side I hope you have seen that I have the tracking code 2 times in the page for 2 different server where different versions of piwik are installed.

When you check for the visitor information are you checking from the intranet side or as an external visitor side of your piwik server?

I was thinking if from the intranet side that maybe you had certain ips to not be tracked hence you not seeing them.

No I am checking from the external side with different IP from all over the world. Different Browser connected with VPN or remote. My own browser has the cockie not to be tracked.

During all the frustration I have uploaded Piwik completely new. It came some error during the installation which all have been fixed. If I now run the diagnostic tool on the weblogin I am getting 1 error:


You need to enable the zlib extension and gzcompress function.

zlib is tagged as active. But this file should handle only the compression and should mostly have only an effect on the Piwik Webpage. Does the new code requires compression? The old code works still fine!

Could it be the apache zlib extension needs updating? When you say its tagged as active i assume you mean in apache?

What php version are you running?

No, if I mean active I mean it has a green tick in the Diagnostic/System Check of Piwik administration. PHP is 5.1.3RC. It is a shared host and I do not have any access to the server configuration.

hmmm maybe the php version is the issue with regards to compatibility to the new version piwik code.

It should work but php 5.3 is recommended.

good luck im out of ideas…

Thanks a lot for the help so far. Maybe somebody has another idea?

try latest beta: Index of /

Thanks Matt,

so far I do not want to upload a beta version. I do not have so much time in the next few days to solve any other big error. (I have to leave my apparment and try to find a new one). Later I will try it.

But I found another interesting thing: If I check the PHP version with the system tools of Piwik I am getting PHP 5.1.3RC.
If I call the phpinfo file it shows PHP Version 5.3.16.

Could it be that there are some files of Piwik not correctly updated? (gzcompress by the way is not activated and will not be because it did not work)