New install unable to see today's data


(Janne) #1

Hi,

Now I can see yesterdays data, but the problem is that Im unable to see today’s data.
Default day is set today, and
time_before_archive_considered_outdated = 10

Now using the script on sites http://www.bitnet.fi[/url] and http://pienipaatos.110mb.com and [url=http://puhetta.uuuq.com]http://puhetta.uuuq.com

Janne


(vipsoft) #2

This symptom has been observed in ticket #479 (Lag in dashboard reporting), but we need more info.

Can you run the test suite in piwik/tests successfully?

Please capture the output of phpinfo().


(Janne) #3

[quote=vipsoft @ Feb 14 2009, 04:38 PM]This symptom has been observed in ticket #479 (Lag in dashboard reporting), but we need more info.

Can you run the test suite in piwik/tests successfully?

Please capture the output of phpinfo().[/quote]

I have read all tickets concerning this issue, but still unable to solve the problem.

phpinfo() can be found phpinfo on my site

The tests give me a blank page. I copy/paste the tests from http://dev.piwik.org/svn/trunk/tests/

Thanks!
Janne


(vipsoft) #4

Running the test suite requires that you create a piwik_tests db, point config.ini.php to it, and run all_tests.php.

I’ll take a look at your phpinfo when I get back to the office.


(vipsoft) #5

On the server hosting your mysql database, what is the timezone setting in my.cnf?


(Janne) #6

system time zone UTC

my local is +2


(Janne) #7

[quote=Janne @ Feb 14 2009, 10:01 PM]system time zone UTC

my local is +2[/quote]

Now i did get the yesterdays (14th) data and the local time now is
12 am here at 15th of february


(vipsoft) #8

If you’re able to modify the master php.ini file (e.g., /etc/php5/apache2/php.ini), try setting the timezone:

date.timezone = UTC
If you can't modify the master php.ini file, try changing these lines in Piwik's index.php and piwik.php:
< date_default_timezone_set(date_default_timezone_get());
to:
> date_default_timezone_set("UTC");
Oh... run this in MySQL:
SELECT @@global.time_zone;
If it isn't "SYSTEM", you'll want to use the local timezone returned. A list of supported timezones can be found in:
http://php.net/manual/en/timezones.php
For example, UTC+2 would be "Europe/Helsinki".

(Janne) #9

[quote=vipsoft @ Feb 15 2009, 02:56 PM]If you’re able to modify the master php.ini file (e.g., /etc/php5/apache2/php.ini), try setting the timezone:

date.timezone = UTC
If you can't modify the master php.ini file, try changing these lines in Piwik's index.php and piwik.php:
< date_default_timezone_set(date_default_timezone_get());
to:
> date_default_timezone_set("UTC");
Oh... run this in MySQL:
SELECT @@global.time_zone;
If it isn't "SYSTEM", you'll want to use the local timezone returned. A list of supported timezones can be found in:
http://php.net/manual/en/timezones.php
For example, UTC+2 would be "Europe/Helsinki".[/quote]

I modify the default timezone in piwik.php and index.php to europe/helsinki and that did it. style_emoticons/<#EMO_DIR#>/smile.gif

Thank you!

Janne


(ezuall) #10

This worked for me as well. I had to set my timezone to CET. It would be great if this issue could be mentioned in the troubleshooting section.

Thank for getting to the bottom of this.
ezuall