New install error session has already been started


#1

Hi I have been trying to install piwik, I tried using cpanel the install appeard to go through fine but when I click on the admin link I got the following error

Error: Unable to start session. Please check that the web server has enough permission to write to these files/directories:
For example, on a Linux server if your Apache httpd user is www-data, you can try to execute:
chown -R www-data:www-data /home//public_html/analytics/tmp/sessions/
chmod -R 0755 /home/
/public_html/analytics/tmp/sessions/
Debug: the original error was
session has already been started by session.auto-start or session_start()

My host said it was the php version and changed it to be 5.1, this allowed me to login but then gave me a load of errors on the dashboard!!

it also showed a box saying I should be using version 5.4 so I changed the php version to 5.4 and now I get the same error as before?

any suggestions I have set folders to 0777 incl the tmp/* folders

thanks

M


(Matthieu Aubry) #2

please ask your host to disable session.auto-start in the PHP configuration

Also pls use php 5.4 it’s always better to use more recent major version.

Also try using Piwik 2.0 which is more stable: New Piwik 2.0 public beta for testers - Analytics Platform - Matomo


#3

I have the same problem since the update of 2.0.1!

php is 5.4 stable
autostart session is disabled
session_save_handler = dbtable

\sessions has 755

So I did all suggestions - error is not fixed…


(Matthieu Aubry) #4

what’s the error?


#5

exacly the same error as described:

Error: Unable to start session. Please check that the web server has enough permission to write to these files/directories:
For example, on a Linux server if your Apache httpd user is www-data, you can try to execute:
chown -R www-data:www-data /home//public_html/analytics/tmp/sessions/
chmod -R 0755 /home/
/public_html/analytics/tmp/sessions/
Debug: the original error was
session has already been started by session.auto-start or session_start()


(Matthieu Aubry) #6

I think you have session.auto-start enabled in your php conf, can you disable, restart server, and try again.


#7

Hi Matt,

the session autostart option is disabled - definitively.


(Matthieu Aubry) #8

Then sorry I dont know… try phpinfo to double check?


#9

Same issue here,

trying all described options didn’t help with 2.01.

I went back to 2.0 which worked perfectly.

PHP 5.3.19


#10

I agree :slight_smile:


#11

Solution:

“Die aktuelle Piwik Installation benötigt eine aktuellere Version des PEAR Paketes Log (Log.php).”

Piwik 2 needs the current PEAR package LOG.


#12

Same problem here. As reneweiss mentioned it is a problem with pear.

Sorry, but this is a really terrible update process. Before starting the update you should
check whether the system fullfils all needed requierments. Instead the update just gets started and
the user is left in front of a missleading error message.

And I see no automatic way to get back to the last working version.


(Matthieu Aubry) #13

@Sithlord well if you look at our blog and twitter we asked so many times for people to test. There are thousands of possibilities of configuration and we never hit your particular problem… I still don’t know how to reproduce the problem so sorry cant help yet


#14

@matt - thx for the reply. it seems to be a problem with a not up-to-date version of pear.
updating pear seems to solve the problem. but there are more obvious issues - for example when
hovered over the folder icons of the realtime visitors there seems to be a css error;
Opening the new visitor profile doesn’t highlight sells anymore (when used with a shop); moreover the last
visit is highlighted in the same yellow as the sells visit which is irritating.

I think the final was perhaps released too soon.

@all
olemo posted a workaround: 301 Moved Permanently
Its NO solution but at least you can continue to work till a final solution is found.


#15

I have narrowed down the issue to this line of code added to my .htaccess file after I install ninja firewall

BEGIN NinjaFirewall

<IfModule !mod_php5.c>
SetEnv PHPRC /home/****/public_html/user.ini

END NinjaFirewall

anyone have any idea how I can get a work around for this I have now updated to 2.0.2 an the problem is still happening?

thanks

M