Need a Bigger VPS or Something Wrong


#1

I wanted to try Piwik so I purchased a small KVM VPS with 512MB memory 512MB swap, and installed Centos 6.6 64bit and set up Piwik. Everything works, and I set up just 4 sites that get around 30 visits a day max. After a day or two I started looking at the statistics and found the interface to be glacially slow. I put htop on the VPS and can see that when it is simply monitoring hits, the load is around 0.2, but the moment I start trying to use the GUI to look at the stats the load goes up to 6 and above.

Does this sound reasonable? In other words, am I overloading my VPS, I should have purchased a bigger VPS, more memory, or have I done something wrong in setup, 4 small sites and using the GUI should not overload a VPS with these resources. Or anything else?


(Matthieu Napoli) #2

I have a Piwik setup on a DigitalOcean VPS with the same specs (512Mb of RAM) and I don’t see any problem (3 sites, ~20-50 visits per day each). Could you check which process is using the CPU, or see if the memory is completely used (and which process is using most of it)?


(Matthieu Aubry) #3

Hi there,

Also make sure you setup: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo


(Matthieu Napoli) #4

4 sites that get around 30 visits a day max

Is the cron archiving really necessary?


#5

Matt’s suggestion is the fix. Thank you. Before setting up autoarchiving of my reports, the GUI interface was unusable. Now I set it up, everything loads reasonably quickly. I’ll set this up automatically next time.


(Matthieu Aubry) #6

Good to know. We also would like in Piwik directly to suggest users to enable the cron script - suggested in: Detect when stats load slowly and explain to user to disable Browser trigger archiving in Admin · Issue #6210 · matomo-org/piwik · GitHub


#7

Matt, thank you for the link to Github. Just so you know, that is an exact description of what I was doing, and what was going wrong. Everything worked fine the first day. After the first day, I wanted to do custom date ranges to see all the search terms used to find the sites. But the panel would never fully load. The more I clicked around the worse it got. I never saw any message about auto-archiving to improve performance.

I’d regard myself as a representative user. I can follow the install instructions, but they took me a lot longer than 5 minutes. I am not a Linux wiz. I may be mistaken, but I am pretty sure they don’t conclude with set-up the cron for auto-archiving otherwise I would have tried or paid someone to help me. My suggestion is that you do add this setup to the instructions. I think it will provide a better experience to your users, and as far as I can tell, there is no downside.

I paid someone to set up auto archiving for me because I didn’t know about system or user cron. That person told me the instructions neglect to advise on setting permissions for the archive directory. If that report is accurate, you may want to consider adding that to the auto archive instructions.

All my suggestions are offered in the spirit of thanks for Piwik and to its success. It is nice to have an alternative to Google Analytics.