Nach Update auf 2.0.1 fehlen die Zahlen einer Monatsübersicht


#1

Hallo Forum,

ich habe im Dezember ein Update von Vers. 1.12 auf 2.01 durchgeführt. Bei einer von 6 Websites fehlern jetzt die Besucherzahlen vom Monat Dezember. Die Zahlen bis November sind da. Der laufende Januar wird auch angezeigt. Stelle ich statt dem Monat Dezember den Zeitraum 1.12.2013 bis 31.12.2013 ein werden auch die Besucherzahlen angezeigt.

Das Update auf die 2.0.2 hat keine Veränderung gebracht.

Kann man den Monat Dezember für die Seite neu berechnen?

Gruß
Wolfgang


#2

Frohes Neues,
genau das Problem habe ich auche gerade.
Mir ist noch aufgefallen, dass beim Umstellen von der Tagesansicht auf die Monatsansicht im Feld “Graph der letzten Besuche” irgend eine Fehlermeldung mit “out of Memory” kam.
Update von 2.0.1 auf 2.0.2 brachte dann ebenfalls keine Besserung.

Auf dem Server läuft PHP 5.3.2. Für den kompletten Dezember dürften das ca. 500 Besucher gewesen sein. Sollte für Piwik ja eigentlich kein Problem sein…

Grüße
Oli


#3

Hallo,

genau dieses Problem plagt mich auch.
Die fehlenden Einträge betreffen nur eine meiner Seiten. Bei allen anderen ist die Statistik in Ordnung.
Ich beobachte mit PIWIK sechs Seiten mit etwa 500 Besuchern pro Monat.
PIWIK läuft auf dem Webspace einer meiner Seiten.


#4

G’day,

Hier genau das gleiche Problem.

Zeitspanne:
TAG und WOCHE im Dezember: Statistik in Ordnung
MONAT Dezember 2013: 0 Besucher
JAHR 2013: 0 Besucher
ZEITSPANNE 1.1.2013 -> 31.12.2013: 0 Besucher
ZEITSPANNE 1.1.2013 -> 30.12.2013: Statistik in Ordnung
ZEITSPANNE 1.1.2013 -> 4.1.2014: Nur 2014 Daten!

Nur bei 31.12.2013 als Enddatum geht es schief.
Darum kann ich auch keine Jahresübersicht erstellen :frowning:


#5

Auch nach Update 2.0.3 noch immer genau das gleiche Problem

Lösung gefunden!

Zweimal neues Beitrag gepostet, zweimal kein Post im Forum :X

Aber jetzt:

Nur die Tabellen piwik_archive_blob_2013_12 und piwik_archive_numeric_2013_12 löschen (umbenennen) bracht nicht, aber ALLE Tabellen piwik_archive_blob_2013_x und piwik_archive_numeric_2013_xx löschen (umbenennen) war die Lösung!

Siehe auch Piwik Ticket: 4465


#6

Ja, bei mir bleibt das Problem unter 2.0.3 auch erhalten.

Also bisher keine Lösung.
Gruß
Wolfgang


#7

Kaum macht man es richtig, schon geht es.

Hier hatte schon mal jemand ein ähnliches Problem:
http://forum.piwik.org/read.php?5,82597

Und hier die entsprechende Stelle in den FAQ:
http://piwik.org/faq/how-to/#faq_59

Ich war dann mal so mutig und habe die Tabellen piwik_archive_blob_2013_12 und piwik_archive_numeric_2013_12 mit phpMyAdmin komplett gelöscht.
(Ok, ganz so mutig war ich nicht. Ein Backup der Datenbank habe ich mir vorher doch gegönnt.)

Dann noch mal gezittert, als beim ersten Aufruf der Dezember Seite eine Fehlermeldung im Feld “Graph der letzten Besuche” auftauchte:

Fatal error: Out of memory (allocated 21233664) (tried to allocate 131072 bytes) in /homepages/…BLA…/htdocs/html/piwik/core/DataAccess/ArchiveWriter.php on line 139

Aber beim zweiten Aufruf war alles wieder gut.
Nachahmung auf eigene Verantwortung.
:)-D


#8

Genau wie ich es heute Morgen auch gelöst, und gepost, habe (den Post ist leider nicht akzeptiert oder so :S )

Monthly report for December 2013 not showing figures

Nur die Tabellen piwik_archive_blob_2013_12 und piwik_archive_numeric_2013_12 löschen (umbenennen) bracht nichts. Darum ALLE piwik_archive_blob_2013_xx und piwik_archive_numeric_2013_xx gelöscht (umbenennt) und alles wieder berechnen lassen…

Resultat: Jahresübersicht 2013 klappt wieder und Dezember Daten sind auch wieder da (:P)

Ad


#9

Schade, zu früh gefreut.

Seit ein paar Tagen schmeißt mir die Monatsansicht wieder Fehlermeldungen aus.
Mittlerweile habe ich vermutlich auch schon den Grund für das Problem herausgefunden. Die Seite des Kunden läuft noch auf einem etwas älteren Vertrag bei 1und1. Dort liegt das Memory-Limit bei nur 32MB. :X

Ich schätze mal, dass bei der Monatsansicht auch noch die Daten für die Archiv-Daten erzeugt werden sollen und daher diese Grenze überschritten wird.

Der Support-Mitarbeiter hat mir zwar zu einem aktuellem Tarif mit höherem Memory-Limit geraten, da ich aber persönlich schon zu viele schlechte Erfahrungen mit 1&1 gemacht habe, werde ich unserem Kunden mal bei Zeiten einen neuen Provider empfehlen.

Bis dahin gibt es bei Ihm halt nur Wochen-Ansichten.


#10

Monthly report for December 2013 not showing figures

Hätte bei mir wahrscheinlich auch funktioniert, wenn ich nicht “Alte Besucher-Logs und Berichte löschen” eingeschaltet hätte um Plattenplatz in der Datenbank zu sparen. Daher hat es nicht funktioniert die beiden Dezember Tabellen zu löschen :frowning: . Danach waren dann auch die Dezemberdaten der anderen 5 Webseiten weg!
Zum Glück hatte ich vor dieser Aktion erst einen MySQL Dump durchzuführt!

Gruß
Wolfgang


#11

Erfolg!

Ich habe alle Archive, wie von “The Adder” beschrieben gelöscht. Nun sind alle Daten OK.
Anfangs versuchte ich, unter Alle Webseiten die Neuberechnung durchzuführen. Das ist, Webspace sei Dank, mit einem Memory Exhaust daneben gegangen. Seite für Seite klappte die Neuberechnung dann aber. Pro Seite dauerte es etwa eine Minute.