Nach Piwik-Update Fehler


#1

Ich hatte ein Auto-Update auf V. 1.5 (von 1.4) machen wollen. Es erschien nur die Fehlermeldung

Piwik and Zend_Session require the ini_set() function

It appears your PHP has disabled this function. To enjoy Piwik, you need remove

ini_set
from your
disable_functions
directive in php.ini.

Ich löschte die Piwik-Version manuell komplett vom Server und updatete manuell. Wieder kam der gleiche Fehler. Ich hoste bei Lima-City.
Danke im Voraus.
Hinker


#2

Bei mir das gleiche Problem wie bei hinker.

Das Update auf 1.5 erzeugt einen Error. Um den zu beheben, soll ich die php.ini Datei ändern. Keine Ahnung wo ich die besagte php.ini finde und ob ich auf die überhaupt Zugriff habe oder doch nur mein Hoster.

Leider habe ich von php wenig Ahnung.

Jetzt kann ich jedenfalls nicht mehr auf Piwik zugreifen.
Kann man das Update irgendwie rückgängig machen?


(Thomas Seifert) #3

@Weihnachtsbäckerei: wenn die Fehlermeldung vor dem Update der Datenbanken erscheint, dann kannst Du einfach die alten Dateien bzw. die alte Version wieder aufspielen. Wenn Du kein Backup hast, dann von http://builds.piwik.org/ .

@hinker: ich würde empfehlen, Deinen Hoster danach zu fragen. Entweder kann er Dir sagen, wo Du das selbst ändern kannst, oder er ändert es, oder er ist dazu nicht bereit.


#4

@thomas
super, dankeschön!
die datenbank ist glücklicherweise noch nicht erneuert worden, so kann ich die alte version wieder aufspielen. und jetzt weiß ich auch wo ich die finde :slight_smile:


#5

Ich hab jetzt die alte Version (1.4.) von Piwik wieder aufgespielt. Jetzt zeigt er aber überall nur noch 0 Besucher an.

Was hab ich falsch gemacht? War die Datenbank doch schon geupdatet? Hilfe!


#6

Okay, hat sich erledigt. Problem geklärt.

Hat einfach in den letzten Tagen nicht getrackt, wegen des Update-Fehlers.

Jetzt ist aber wieder alles okay!


#7

Ich werd das Downgrade heute probieren… Hatte vorher keine Zeit. Danke