Mysqli statement execute error : Incorrect arguments to mysqld_stmt_execute


#1

Hi there,
I’ve been using Piwik for some months now and never had any problems. Today when opening Piwik, the following error was shown, Piwik cannot be opened:
“Mysqli statement execute error : Incorrect arguments to mysqld_stmt_execute”

I did not change anything, so I am wondering where this error came from and what I can do?

Kind regards, Fran


#2

Hi,
I have the same problem, too.
I use release 2.15.0 since october and everthing runs fine.
Nothing was changed, but today when opening piwik the same error occurs.

Thanks in advance and kind regards,
ur


#3

I tried to update Piwik today, as I was using an old version. After uploading the new files and opening Piwik I get the same error.
The URL in the address bar is http://myURL/index.php?module=CoreUpdater&action=
so it seems like it’s trying to do the update, but the error remains. So I cannot even update. :frowning:


#4

SOLVED!! At least for me.

My piwik runs on a webhosting at 1&1. I don’t know what happens but over night the php version changed to undefined. This triggered this error. After I explicitly set PHP to 5.5 for my piwik domain everything is running again. Php version can be changed at 1&1 control center at php settings.

Many thanks and kind regards,
ur


#5

Thank you so much, that did the trick! I just spoke to the 1&1 support and they said that they have a problem with an update or something and they are working on a solution. They did not mention your workaround though :slight_smile:


(richtungspfeil) #6

Thank you! It´s working!