Multi Site Management


#1

Hi,
I’ve recently started with piwik, so maybe it’s just my fault by doing something wrong, but after I’ve added a second site to piwik I can’t switch between them as the second site isn’t showing up in the dropdown. On “All Websites” I only get an error (“ou can’t access this resource as it requires an ‘view’ access for the website id = 1”). Or with id = 2 if I am in the second site. Only way to switch between those two is via switching to settings > websites and viewing the tracking code. Then the Dashboards shows the other site.


#2

Push


(Matthieu Aubry) #3

could you please upgrade to latest piwik beta? I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo


#4

Updated to 2.4.0-b7. But still no difference

Btw I’ve got more things not working. I can’t change the date range. Every selection stays at “day”.
Visitor Map stays at “loading” state
Keywords, Referrer Sites and Search Engines stay empty
"all websites" Button leads to "Oops… problem during the request, please try again. "

I’ve tried a complete reinstall, but nothing changed. Looks like I have to stick to Analytics :frowning:


(Matthieu Aubry) #5

It should work. If you’re patient enough we can find solution.

Can you check in your server error log file if there is some interesting error there?


#6

Hey there,
thanks for giving not up on me :slight_smile:
But the only error I get is the following:

[Thu Jun 26 09:11:49 2014] [error] [client 212.186.199.17] File does not exist: /var/www/lisaundgiorgio.at/www/html/piwik/misc/user/favicon.png
[Thu Jun 26 09:11:49 2014] [error] [client 212.186.199.17] File does not exist: /var/www/lisaundgiorgio.at/www/html/piwik/misc/user/favicon.png

I don’t think this should cause those problems.


(Matthieu Aubry) #7

can you try with a different browser?

or disable browser extensions?

If you still have problem please PM this forum post URL and your piwik url and login details, i’ll take a look


(Matthieu Aubry) #8

When I connect to your Piwik I see some error notifications. Then I look with Web developer console in my browser, and in the Network tab, I see that there are redirects from index.php --> index on your server. These redirects are causing the problem. Please check your server does not try to redirect index.php requests to index (without .php)


#9

Thanks mate. That did the trick.