Message d'erreur chez OVH

Bonjour

Depuis plusieurs semaines il m’est impossible d’ouvrir Matomo (Piwik)
J’ai tenté une réinstallation complète mais toujours ce même message d’erreur :
An error occurred
SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

Y a t-il quelque chose de particulier à faire chez OVH ?
Je suis en mutualisé version PHP 7 et mysql 5.5

Merci
Maryl

Hi,

This may help you:

https://matomo.org/faq/troubleshooting/faq_183/

Merci pour la réponse

Je comprend d’où vient le problème mais je ne parviens pas à trouver ce fichier my.ncf qui est si j’ai bien compris dans mysql ça me semble assez complexe pour moi.

Mary

Je reviens pour donner les infos que j’ai eu.
Ne trouvant pas comment accéder à ce fichier my.cnf j’ai donc contacté mon hébergeur OVH, je suis en mutualisé et voici leur réponse:

En effet, les paramètres sont pré-configurés et communs sur tous les serveurs mutualisés et ne peuvent pas être personnalisés, nous procédons à des mises à jour périodiques selon les exigence techniques.
Vous pouvez prendre connaissance de la configuration du serveur sur lequel votre hébergement web est installé à partir de ce lien :
phpinfo()
Si vous voulez, vous pouvez opter pour les offres d’hébergements dédiées qui permettent la personnalisation de la configuration du serveur.

C’est très sympa de leur part de me proposer un mutualisé pour 15 fois plus cher qu’un hébergement pro.

Je suis bien déçue car ça veut dire qu’avec OVH je dois faire une croix sur l’installation de Matomo (Piwik)

Si quelqu’un a réussi à faire l’installation sur un OVH mutualisé …

Cordialement et merci à Lukas pour le lien

Maryl

Hi,

That’s odd. Have you told the support that you are getting an “Mysql Server has gone away” ?
Maybe they know another solution for their hosting.

Oui j’ai bien précisé le message d’erreur,
Voici notre échange:
mon premier message:

Bonjour
J’utilise Piwik pour gérer mes statistiques depuis plusieurs années.
Depuis 2 mois Piwik ne fonctionne plus même après une tentative de nouvelle installation sur une autre bdd.
Lorsque j’ouvre Piwik j’ai ce message :
An error occurred
SQLSTATE[HY000]: General error: 2006 MySQL server has gone away
Y a t-il une solution que vous puissiez m’apporter pour régler ce problème.
A noter que tout fonctionne bien sur un hébergement de base 1and1 php 7 mysql 5.5, je souhaiterais pouvoir conserver mes domaines chez OVH que j’apprécie depuis plus de 10 ans.
Cordialement
Maryl S.

Leur réponse

Bonjour
Vous nous avez contacté pour nous signaler une erreur sql sur votre site
Après vérification, je constate que le dysfonctionnement semble être lié à
l’environnement d’exécution de votre hébergement.
Je vous propose de le mettre à jour vers la version stable, voici la démarche
à suivre depuis votre espace client :
Cliquez sur votre domaine sous la section “Hébergements”,
Allez dans l’onglet “Informations générales” → “Configuration” → “Modifier la
configuration”,
Choisissez l’environnement d’exécution “Stable”,
Patientez quelques minutes après la validation.
Il est possible que cela provient des requêtes SQL qui mettent trop de temps à
s’exécuter.
Nous vous invitons donc à vérifier votre module piwik afin d’optimiser votre
script.
Je reste à votre disposition pour toute demande complémentaire.
Cordialement,

Ma réponse après avoir fait les changements indiqués

Bonjour
Merci pour votre réponse, j’ai fait le changement pour une version stable comme vous me l’avez indiqué depuis 3 quart d’heure mais toujours le même message d’erreur.
Je vais dans l’après- midi refaire une installation complète de piwik et je vous tiendrais au courant.
Après quelques recherches de mon côté, ce serait du au fichier my.cnf
"Pour corriger, vous pouvez augmenter la limite maximale
de taille de paquet max_allowed_packet dans le fichier my.cnf, par exemple définissez max_allowed_packet = 128M "
Mais je suis bien incapable d’accéder à ce fichier qui, si j’ai bien compris est dans mysql
Merci encore de votre aide

et ensuite leur dernière réponse:

Madame
En effet, les paramètres sont pré-configurés et communs sur tous les serveurs
mutualisés et ne peuvent pas être personnalisés, nous procédons à des mises à
jour périodiques selon les exigence techniques.
Vous pouvez prendre connaissance de la configuration du serveur sur lequel
votre hébergement web est installé à partir de ce lien :
phpinfo()
Si vous voulez, vous pouvez opter pour les offres d’hébergements dédiées qui
permettent la personnalisation de la configuration du serveur.
Pour découvrir nos offres, veuillez consulter les liens suivants :

Voici donc le fil de notre conversation

Désolée de vous répondre en français mais je maitrise très mal l’anglais
Mary

Bonjour me voici de retour dans le but de vous tenir informés

Leur ayant fait part de ma déception sur le fait que OVH ne pouvait pas faire fonctionner Matomo alors que ça fonctionne chez d’autres hébergeurs avec des hébergements de base et que j’envisageais une migration de mes domaines chez le concurrent.
Ils ont donc revu leur réponse que voici:

Bonjour ,
En effet, il n’est pas possible de modifier la configuration d’un hébergement mutualisé ( le fichier php.ini ). Pour cela, il est recommandé de prendre un hébergement dédié.
Concernant l’installation de Piwik, votre demande fait l’objet d’une remontée auprès de nos administrateurs afin de déterminer l’origine de ce souci.
Je reviendrai vers vous dès que j’aurai un retour de leur côté.
Je vous invite à patienter et je vous remercie pour votre compréhension

Je vais donc patienter en espérant qu’ils vont trouver la solution.

Merci
Maryl

1 Like

Bonjour j’ai une installation Matomo sur un hebergement mutualisé OVH qui tourne sans problème. Il me semble avoir eu une erreur de se type il y a quelques temps que j’ai simplement résolu en nettoyant ma base de donnée en passant par myphp.

En espérant que cela fonctionne pour toi.

Bonjour

Merci pour ta réponse,
Matomo est effectivement installé dans une bdd où j’ai d’autres tables j’ai donc créé une nouvelle bdd toute neuve, toute vide et installé matomo dedans et toujours le message d’erreur.
J’ouvre sur l’index, j’ai bien la fenêtre qui me demande mot de passe et utilisateur que je rentre et ensuite ça mouline, ça mouline et j’ai la fenêtre d’erreur.

ça c’est produit quand je suis passée en php7, et si je reviens en php 5.6 le problème reste.

Tu es repartis sur une install toute neuve ou tu as réimporté ton ancienne base de donnée. Car si il y a un soucis dans la base et que tu la déplace tu ne fais que déplacer le probleme.
As tu essayer de nettoyer la base dans phpmyadmin, comme celà :

J’ai fait une installe toute neuve avec un nouveau téléchargement de matomo

1 Like

Comme je le disais j’ai fait une installation toute neuve avec un nouveau téléchargement et installé dans la nouvelle BDD vide
Même problème j’ai optimisé les tables comme indiqué avec succès, mais toujours ce “serveur has gone away”

2018-01-19_194607

J’ai fait la même chose sur mon ancienne bdd qui a l’ancienne installation
et là erreur et bien sûr toujours le “serveur has gone away”

2018-01-19_194317

Faut pas trop se fier aux réponses du support OVH. Ils tombent toujours à côté. J’avais un Matomo sur un hébergement PRO à 7€ TTC/mois sans config particulière. Ca a tourné quelques temps et du jour au lendemain l’archivage est devenu impossible (base à 1.6Go alors que la limite est à 2Go). Divers problèmes et timeouts et impossible de supprimer les anciens logs visiteurs depuis l’interface Matomo. Les visites étaient toujours prises en compte mais l’archivage impossible.
Je me suis donc résolu à prendre un dédié (toujours chez OVH mais là au moins ça ne dépend que de moi) qui ne sert qu’à Matomo et où j’ai migré mes anciennes bases. Je tourne à environ 10.000 visites et 75.000 pages par jour. Payer un serveur dédié 40€ par mois chez OVH reste donc plus économique que le cloud Matomo qui pour ce volume me coûterait 600€ par mois. Je pense que mon dédié, compte-tenu des ressources utilisées pour 75.000 pages / jours pourrait en encaisser sans difficulté 1 million. Mais ça me plombe de devoir payer 480€ par an pour un serveur.

En regle générale, je dirai qu’il vaut mieux mettre matomoto sur un vps plutot que du mutualisé. la base de données peut grossir vite selon les sites que tu monitores, et les besoins avec. Il faut pouvoir avoir acces au parametrage de mysql et php, ce qui est bien souvent impossible en hebergement mutualisé. Deplus leur support se limite à regarder les logs, la version de ton install et en profiter pour trouver que ton appli est en cause et pas l’hebergement…tu peux trouver des vps pas cher chez ovh, et pour avoir testé plusieurs hebergeurs, ils restent le meilleur rapport qualité / prix

Bonjour
Merci pour vos réponses

Il s’agit d’un site associatif qui tourne tranquillement 1 centaine de visites par jour et la bdd n’occupe que 400mo sur 2 Go il y a de la marge et même sur une nouvelle installation toute neuve dans une nouvelle bdd toute vide même problème.
J’ai un autre hébergement chez 1and1 et là ça tourne comme il faut, j’ai donc opté pour cette solution, matomo est installé chez 1and1, tout fonctionne.

Merci et Bonne journée @ vous