Mes stats à 0 depuis installation (- de 1 semaine)


#1

hello ,

je viens de mettre en place Piwik stats depuis moins d’ une semaine , ma “Vérification du système” ( m’ indique )

"Génial! Il n’y a aucun problème avec votre installation de Piwik. Donnez vous une tape dans le dos. "

et pourtant 0 partout , j’ ai d’ autres stats par mon hébergeur ( Strato-hebergement.fr ) , moins détaillées mais avec des visiteurs … même si je n’ ai pas des centaines de visites par jour . sur Xiti aussi , j’ ai des visites …

  • je ne l’ ai pas mis sur la 1ère page ( index.html avec redirection après 5 secondes) , mais sur la 2è la page index1.html ( la redirection ), et c’ est bien configuré dans les paramètres > sites : sur index1.html
  • faut il simplement attendre plus d’ une semaine ???
  • j’ ai beaucoup de javascript sur mon site , y aurait il parasites entre deux scripts ? le script Piwik est bien juste avant

merci de votre attention ,

bye,
Jeff


http://www.wi2c.com/index1.html


(Matthieu Aubry) #2

Cela devrait fonctionner, mais il y a beaucoup de raisons possibles que ca ne fonctionne pas, voir cette FAQ: Troubleshooting - Analytics Platform - Matomo


#3

Bonjour,
Même soucis … et j’ai passé l’après-midi et la soirée là-dessus en testant pas mal de trucs !!!
Je suis en mutualisé chez 1and1
J’ai installer piwik qui me dit que je peux me mettre une petite tape dans le dos …car tout est OK
Sauf que, comme pas mal de gens, je n’ai pas de données qui entent dans la base !
1 - je ne suis pas pro du php ou de javascript … donc est-ce que mon code suivi est bon ? car le code donné à la fin de l’install n’était pas le même que celui qu’on me donne dans l’interface piwik ( guillemets ou pas sur le numéro setsiteid )
Quelle est la commande ssh qu’il faut mettre pour le cron ?


<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["trackPageView"]);
  _paq.push(["enableLinkTracking"]);

  (function() {
    var u=(("https:" == document.location.protocol) ? "https" : "http") + "://piwik.netemeraude.com/";
    _paq.push(["setTrackerUrl", u+"piwik.php"]);
    _paq.push(["setSiteId", "1"]);
    var d=document, g=d.createElement("script"), s=d.getElementsByTagName("script")[0]; g.type="text/javascript";
    g.defer=true; g.async=true; g.src=u+"piwik.js"; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="http://piwik.netemeraude.com/piwik.php?idsite=1" style="border:0;" alt="" /></p></noscript>
<!-- End Piwik Code -->


(Matthieu Aubry) #4

il y a des erreurs javascript sur votre site, netemeraude.com/

donc le tracking Piwik ne peut pas s’executer peut etre