"Memory exhausted" while trying to install 3.0.1


I’m trying to install Piwik 3.0.1. When accessing /index.php to do the install, here’s what I get:

"PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 135168 bytes) in /www/<vhost>/core/FrontController.php on line 416

I tried to push the memory size up to 512MB to no avail.

Here’s the server specs:

  • FreeBSD 11.0
  • Nginx 1.10.2
  • PHP 7.0.14 via PHP-FPM

Am I missing something?

Thanks for your help!

So: downgrading to Piwik 3.0.0 gave me more information. I was missing PHP’s ctype extension. It was throwing a

Fatal error: Call to undefined function ctype_alnum()

error. From there, I could work out what was missing. Re-trying with 3.0.1 after install the extension worked.

Case closed, but it’s weird that 3.0.1 wouldn’t throw this error but instead use all available memory.

that’s really weird because nothing’s changed in 3.0.1 around this code. Good that you could find a way to proceed!

Had the same issue when I tried to install Piwiki 3.0,4 on a vanilla server under SLES 12. Tried to increase the memory_limit parameter up to 4G without any success.
I installed php7-ctype like suggested and It works now.
Maybe adding php7-ctype and php7-json as prerequisite would help.