Matomo zeigt keinerlei Daten


(Daniela S) #1

Guten Tag!

Ich habe ein Problem mit Matomo und auch langsam keine Lust mehr :frowning:
Zuerst hatte ich es bei All inkl. falsch installiert, dass fast mein kompletter Blog verloren war. Jetzt läuft alles wieder.
Ich habe dieses Piwik Plug in und es zeigt an "Vielen Dank für die Verwendung von WP-Matomo!
WP-Matomo 1.0.19 wurde erfolgreich mit Matomo 3.4.0 verbunden. Du verwendest WordPress 4.9.3. ". Es zeigt aber keinerlei Daten an :frowning: Ich habe extra ein paar Leuten Bescheid gegeben sie sollen auf meinem Blog surfen aber nichts passiert. Weder bei Wordpress in derm Plugin noch auf meiner eigentlichen Matomo-Seite :frowning:

Meine Seite ist https://danivomdach.de/

Ich habe leider nicht viel Ahnung aber mit einem Bekannten grob abgesprochen, was ich eingestellt habe. Er meinte es müsste so gehen.

Ich hoffe ihr könnt mir helfen. Langsam verzweifel ich nämlich :frowning:


(Lukas Winkler) #2

Hallo,

Das Problem ist schnell gefunden:

Versuche mal https://matomo.danivomdach.de/ aufzurufen. Du wirst einen Browser-Fehler bekommen, da das SSL-Zertifikat dafür ungültig ist, weil du es noch nicht eingerichtet hast.

Kein SSL (also HTTPS) einzurichten ist auch keine Lösung, da deine Seite per HTTPS erreichbar ist und es nicht erlaubt ist dynamische Inhalte von nicht sicheren Seiten in sichere Seiten einzubinden.


(Daniela S) #3

Wie mache ich das denn für die matomo-seite? Bei meiner eigentlichen Blog-Seite hat es ein Bekannter gemacht. Oder muss ich da bei Matomo nur etwas anklicken (ich hoffe^^) ? :slight_smile:

Danke für die Antwort!


(Lukas Winkler) #4

Hallo,

Das HTTPS-Einrichten hat nichts mit Matomo zu tun. Das muss dein Webseiten-Host machen und es hängt komplett von deinem Host ab, wie es funktioniert und ob es was kostet (eigentlich sollte es nicht).


(Daniela S) #5

Aber meine eigentliche Seite hat ja ein SSL Zertifikat. Also muss ich auf der Matomo Seite sowas auch noch bekommen?


(Lukas Winkler) #6

Genau, denn in eine HTTPS-Seite dürfen niemals dynamische Inhalte von einer nicht-HTTPS-Seite eingebunden werden.


(Daniela S) #7

Ich habe keine Ahnung wie ich das machen soll :frowning:
Meinst du das könnte mir helfen?
https://matomo.org/faq/plugins/faq_21/


(Lukas Winkler) #8

Hallo,

Das hat nichts mit Matomo zu tun, sondern muss dein Webhost einrichten.


(Daniela S) #9

Ich rufe die mal an…


(Daniela S) #10

Ich habe das hier in einem anderen post gefunden

"du musst in
/piwik/config/config.ini.php
folgendes reinschreiben:

force_ssl = 1

Danach verschwindet diese Meldung und es wird auf ssl umgestellt."

Geht das so auch?


(Lukas Winkler) #11

Hallo,

Das funktioniert erst, nachdem du das SSL-Zertifikat richtig eingerichtet hast. Dadurch wird jeder auf die HTTPS-Version umgeleitet.


(Daniela S) #12

Ich habe es umgestellt :slight_smile: Aber irgendwie funktioniert es immernoch nicht


(Lukas Winkler) #13

Hallo,

HTTPS ist jetzt richtig eingerichtet und das Problem ist jetzt gelöst.

Jedoch gibt es ein größeres Problem:

Du verwendest blogfoster, welche schon den Tracking code zu ihrer eigenen Matomo-Instanz in deiner Seite eingebunden haben. (genauer gesagt verwenden sie nicht Matomo, sondern ein Produkt von PiwikPro, dass eine alte Version von Matomo verwendet).

Es ist aber technisch nicht möglich zwei Tracking codes gleichzeitig zu verwenden. Man müsste den ersten anpassen, dass er die daten auch an deinen Matomo server schickt (was aber vermutlich nicht geht) oder noch besser das tracking von Blogfoster entfernen (ich weiß immer noch nicht genau, was die sind).

Du hast aber noch ein (eher rechtliches) Problem:

Deine Webseite sendet auch alle Besucherdaten an Google (über Google Tag Manager und Google Analytics) und bindet viele Daten von Google-Servern ein, aber die Datenschutzerklärung ist nicht vorhanden:
https://danivomdach.de/impressum-datenschutz/
Gerade jetzt mit der Datenschutzgrundverordnung/GDPR ist es wirklich wichtig so wenige persönliche Daten wie möglich zu tracken (was mit Matomo möglich ist) und nutzer transparent darüber zu informieren ( und ihnen auch einen opt-out und weiteres zu bieten).


Mir ist gerade aufgefallen, dass du eh eine Datenschutzerklärung hast und nur der Link im Banner falsch ist.


(Daniela S) #14

Welcher Link genau?
Ich werde Matomo wieder runter werfen. Muss nur gucken wie, damit ich nicht meinen ganzen Blog lösche^^


(Lukas Winkler) #15

Screenshot_20180607_095017

Der Datenschutz-Link


(Daniela S) #16

Oh, vielen Dank! ich muss jetzt mal schauen, wie ich bei All Inkl. den Trackingcode von Matomo wieder raus bekomme