Matomo wordpress problem - php cli

We have installed Matomo for WordPress in our site, but it doesn’t work.
We have the following problem: “Your PHP cli version is not compatible with the Matomo requirements. Please upgrade your PHP cli version, otherwise, you might have some archiving errors.Your PHP cli does not load the MySQLi extension. You might have archiving problems in Matomo but also others problems in your WordPress cron tasks. You should enable this extension.”

We have updated the php version and we have also verified the correct enabling of the MySQLi extension.
Unfortunately the problem persists.
How can we fix?

Hi Francesco,

In several cases, your PHP version is different of your PHP CLI version.
Be sure to update the right one (or both).

What is your OS on your server ? A bundle of PHP extensions may be available for you to get rid of your problem !