Matomo with XAMPP

I installed Matomo using Xampp. All the installation was done properly. The database was set up in phpmyadmin. All the tables were created properly. I created a test website in xampp/htdocs. I pasted the tracking code in- between the head tags.
Still, Matomo dashboard is showing “no data is being recorded”. Could anyone please help me with this?

1 Like

Hi,

The first step would be to check your browsers developer tools on the tracked website.
Do you see an error in the console? Do you see the request to matomo.js and matomo.php in the network tab?

Hi,
Thanks for replying!
Yes, I can see both matomo.js and matomo.php in the networks tab.

Hi,

As a next step you can temporarily enable https://developer.matomo.org/api-reference/tracking-api#debugging-the-tracker which makes Matomo return a verbose log on how the data has (or hasn’t been) stored in the matomo.php request.

Before you could also check you haven’t enabled DoNotTrack in the browser you are testing with as Matomo respects that header.

1 Like

Hi!
Thanks soo much!. I am able to track right now. “Do not track” was enabled. Now its working. But I have another question. Suppose I paste the tracking code in a website that is already been deployed in some other server, will I be able to track it using Matomo in XAMPP?

Hi,

That depends on how your Matomo setup works. The domain where Matomo is set up has to be reachable by the website visitor and if your Website uses HTTPS (which it should), Matomo also needs to be set up with HTTPS (which it should be anyway as you are otherwise transferring personal data unencrypted).

Hi!

Ok. I understand what you are telling. But if a users browser has “Do not track” enabled, then we wont be about to track their data? If yes, then is there any way around this issue?

Hi,

In the Matomo settings, you can disable that Matomo respects the DoNotTrack setting (but keep in mind to be compliant to your local privacy laws).

1 Like