Matomo verbindet sich nicht


(Steffi) #1

Hallo zusammen,
ich habe Matomo via FTP direkt in den WP Ordner geladen. Die Installation hat auch geklappt. Dazu habe ich aber eine extra Datenbank angelegt und auch in der Installation angegeben.
Jetzt habe ich das Problem, dass sich Piwik nicht verwinden kann. Wenn ich auf “Seite untersuchen” gehe, dann kommt ein 403 er Fehler, dass /piwik/piwik.php nicht aufgerufen werden kann. Die Ordnerrechte sind bei 755, bei php bei 644. Der Trackingcode ist vor dem /header eingebunden.
Liegt es daran, das die Installation, die ich via FTP hochgeladen habe evtl. in einer anderen Datenbank (dann eigentlich ja bei WP) liegt, wie die extra angelegte Datenbank? Auch das Plugin WP Matomo kann sich via API nicht verbinden. Es ist auch der 403 er Fehler.
Ich bin leider nicht so die Fachfrau, vielleicht steh ich auch nur auf dem Schlauch. Würde mich aber über eure Hilfe freuen.

Steffi


(Fabian Dellwing) #2

HTTP 403 bedeutet: Der Webserver erlaubt den Zugriff nicht.

Grundsätzlich 2 Dinge zu dem was du getan hast:

Matomo gehört in einen eigenen Ordner und nicht direkt in den WP Ordner.
Matomo sollte eine eigene Subdomain haben, wenn irgendwie möglich.

Du kannst mir gerne mal einen Link zu deiner Seite via PN schicken, dann schaue ich mal ob ich noch was sehe. (Damit das mit der PN geht, hab ich dir soeben eine geschickt auf die du antworten kannst.)


(Lukas Winkler) #3

Ich würde

so interpretieren, dass Matomo eh in einem eigenen Ordner liegt.


Wie gesagt, eine Subdomain ist besser, aber so muss es auch gehen.

Am einfachsten wäre es, wenn du (oder dein Serverhost) Zugriff auf die Apache (oder sonstigen Webserver) Log-Datei hättet. Dort sollte ziemlich klar drinnenstehen, warum der Server 403 zurückgibt.

Eine Möglichkeit wäre, dass in der .htaccess von Wordpress irgendwelche Regeln drinnenstehen, die es verbieten PHP-Dateien direkt aufzurufen und die auf für Unterordner gelten (deshalb ist eine eigene Subdomain prinzipiel besser.


(Steffi) #4

Genau, Matomo ist schon in einem eigenen Ordner, aber im WP Verzeichnis. Leider funktioniert aber im Moment noch nicht mal mehr der Link zu Piwik: Sign in - Matomo es läd und läd, ohne etwas anzuzeigen.
ich habe gestern die config Datei angesehen und wie ich mich kenne die Wordpad Datei ausversehen falsch formatiert wieder mit einem Doppelklick hochgeladen… Natürlich ohne vorheriger Sicherung.

An den Hoster habe ich auch schon geschrieben, aber noch keine Antwort erhalten.
Wie das mit der eigenen Subdomain funktioniert, check ich irgendwie nicht. Hatte schon eine angelegt, aber die ging dann nur wie folgt: https://matomo/joyfulfood.de. Somit hab ich diese wieder gelöscht. Bei meinem Hoster habe ich leider auch nur einen FTP Zugang. Den benutze ich ja schon für meine Hauptdomain: https://joyfulfood.de

Ich komme da mit dem Anlegen der Subdomain nicht weiter. Ist es schlimm, wenn die Matomo-Installation auf einer anderen Datenbank liegt, wie die direkt für die Matomo Daten angelegte Datenbank? Es sind dann ja wieder mehr Requests notwendig, oder? Vielleicht funktioniert es einfach auch deswegen nicht richtig.


(Fabian Dellwing) #5

Ich habe mir das ganze jetzt mal angeschaut.

Der Trackingcode ist korrekt soweit ich das sehen kann.
Deine Seite trackt außerdem noch in eine 2. Matomo Instanz und zwar diese hier: https://insights.blogfoster.com/v1/4013.js
Die Loginseite (Sign in - Matomo) von Matomo funktioniert korrekt bei mir.
Die Tackerseite (https://joyfulfood.de/piwik/piwik.php) funktioniert auch korrekt.

Das bringt uns zu dem logischen Schluss: Das Problem liegt an den GET Parametern des Trackercalls.

https://joyfulfood.de/piwik/piwik.php?action_name=Essen aus Leidenschaft, Futter für die Seele - Joyful Food&idsite=1&rec=1&r=398402&h=11&m=37&s=33&url=https://joyfulfood.de/&urlref=https://forum.matomo.org/t/domain/27856/2&_id=cd6156886f03a8a6&_idts=1523698099&_idvc=1&_idn=0&_refts=1523698099&_viewts=1523698099&_ref=https://forum.matomo.org/t/domain/27856/2&send_image=1&pdf=0&qt=0&realp=0&wma=0&dir=0&fla=1&java=0&gears=0&ag=0&cookie=1&res=1920x1080&gt_ms=300&pv_id=YqnFjB

Ich habe mir dann mal etwas angeschaut welche Parameter problematisch sind und bin auch zu einem Ergebnis gekommen:

https://joyfulfood.de/piwik/piwik.php?action_name=test&idsite=1&rec=1&r=398402&h=11&m=37&s=33&_id=cd6156886f03a8a6&_idts=1523698099&_idvc=1&_idn=0&_refts=1523698099&_viewts=1523698099&send_image=1&pdf=0&qt=0&realp=0&wma=0&dir=0&fla=1&java=0&gears=0&ag=0&cookie=1&res=1920x1080&gt_ms=300&pv_id=YqnFjB

Dieser Aufruf funktioniert. Entfernt habe ich: _ref, urlref und url. Außerdem musste ich den action_name unbrauchbar machen.

Deine Aufgabe wäre es jetzt also von Strato zu erfragen was der Mist soll und dass sie das bitte anpassen sollen.


(Steffi) #6

Oh, vielen Dank. Strato hat sich leider bis jetzt noch immer nicht gemeldet. Ich denke mal, Montag dann. Der Service dort ist leider nicht so der Hit, 24/7 gibt’s nur gegen Aufpreis… das ist es auch, was mich dort zusätzlich noch stört.
Kann ich den geänderten Code nicht selbst wo einfügen? Ich versteh jetzt nur nicht so ganz, wie Strato die Parameter falsch setzt, bzw. was die jetzt genau machen sollen - sorry. Theoretisch die GET Parameter des Trackercalls bei Piwik ändern?


(Fabian Dellwing) #7

Nein, die Parameter können nicht verändert werden, da sie von Matomo so vergegeben sind. Allerdings ist der Webserver so konfiguriert, dass er die Anfragen blockt wenn diese Parameter da sind. Ergo muss die Konfig des Webservers angepasst werden, da du darauf aber wohl keinen direkten Zugriff hast, muss Strato da helfen.

Falls du dich nach nem neuen Hoster umsiehst: Ich persönlich hab Zeit meines Lebens nur Root-Server gemietet, aber da bin ich zufriedener Hetzner Kunde.


(Steffi) #8

Ah, ok. Verstehe. Dann werd ich am Montag doch gleich mal direkt mit Strato telefonieren.
Tatsächlich, die Matomo Startseite funktioniert. Scheinbar nur im Chrome nicht. Bei Firefox hat es geklappt. Es sind doch auch tatsächlich schon ein paar Daten vorhanden. Allerdings sind es viel weniger Aufrufe als über WP Stats, GA oder Piwik bei Blogfoster. Ca die Hälfte nur.


(Lukas Winkler) #9

Hallo,

wie @fdellwing schon herausgefunden hat, scheint der Server die Anfrage zu blockieren, wenn sie action_name=Essen aus Leidenschaft, Futter für die Seele - Joyful Food enthält. Da kann Matomo nicht viel dagegen machen, dass solltest du wirklich dem Support schreiben. Ein Grund könnte “mod_security” sein, das auf einigen Servern standardmäßig aktiviert ist und “seltsam aussehende” Anfragen blockiert.

Dem kann ich mich prinzipiell nur voll anschließen. Nach jahrelang unzähligen Problemen mit verschiedensten Webhostern, habe ich vor 2 Jahren einen vServer (auch bei Hetzner) gemietet und habe seitdem alle meine Seite dort laufen und keine Probleme mehr.

Natürlich sind grundlegende Linux-Kenntnisse hilfreich, aber mit etwas Aufwand kann man so einige Webseiten gleichzeitig hosten und es ist auch deutlich günstiger als bei einien Webhostern.


(Steffi) #10

So mit Strato ist das abgeklärt. Es liegt wohl am Plugin iTheme Security. Ich hatte es ausgeschalten, dann funktioniert es. Die Frage ist nun natürlich, welche Einstellung dies verursacht und ob iTheme Security wirklich nützlich ist, oder ob es andere Alternativen gibt.


(Fabian Dellwing) #11

Leider kann ich dir bei WP Plugins garnicht helfen, wir nutzen hier in der Firma als CMS nur Drupal und ansonsten PHP oder Java Frameworks.

Nach den Informationen die ich der Pluginseite entnehmen konnte, könnte es möglich sein das störende Verhalten abzuschalten ohne das komplette Plugin zu deaktivieren. Aber wie und was, keine Ahnung.