Matomo trackt plötzlich nur noch "Wiederkehrende Besucher"


(Christoph) #1

Hallo… der Titel mag merkwürdig klingen, ist aber so.

Vor ca. 2 Stunden stellte ich einen massiven Einbruch meiner Suchgriffszahlen auf meiner Seite fest (> 80%).
Mein erster Gedanke war natürlich: Serverproblem!
Nachdem ich dieses schnell prüfte und ausschließen konnte, war meine nächste Idee: Google-Penality (3/4 meiner Besucher kommen über Google / organisch). Nachdem ich aber auch hier feststellen musste, dass meinen Rankings nichts zugestoßen ist, habe ich mir den Live-Besucher-Bericht von Matomo angeschaut… und siehe da: Seit fast drei Stunden nicht ein neuer Besucher, nur “Wiederkehrer”. Und das ist schlicht unmöglich.

Jemand eine Idee?


(Lukas Winkler) #2

Hallo,

Kommen alle diese Nutzer von derselben IP-Adresse? Kann es sein, dass du (oder dein Host) die Server-Konfiguration verändert hast?


(Christoph) #3

Nein, nichts dergleichen… Die Webseite und Matomo laufen auf zwei unterschiedlichen Host-Systemen (beides vServer bei unterschiedlichen Providern).
Mir sind seitens der Provider keinerlei Änderungen an der Konfiguration bekannt. Webseite + Matomo-Server haben eine feste IP, die sich auch nicht geändert hat.


(Lukas Winkler) #4

Hallo,

Hm, der einzige Gedanke, den ich dazu habe, wäre dass Matomo hinter einem reverse Proxy ist und daher die IP der Besucher nicht mehr sieht. In dem Fall müsste man Matomo wie hier erklärt konfigurieren:

https://matomo.org/faq/how-to-install/faq_98/


(Christoph) #5

OK, falscher Alarm!
Ich habe es selbst verbockt! Es wäre schwer jetzt alles im Detail zu erklären, aber mein Problem gründete sich auf der Tatsache, dass ein falsch gesetztes Cookie dafür sorgte, dass Matomo bei neue Besuchern gar nicht geladen wurde…
Sorry für die Umstände… dennoch vielen Dank