Matomo Trackt einfach nicht


(Klaus) #1

Guten Morgen alle zusammen,

ich versuche nun seit ein paar Tagen Matomo zum tracken zu bekommen, leider ohne Erfolg.
In der Vergangenheit haben wir noch Piwik benutzt, Website und Piwik waren damals auf einem Server.
Matomo läuft jetzt auf einem anderen Server und der Code wurde ebenfalls entsprechend angepasst.

<!-- Matomo -->
<script type="text/javascript">
  var _paq = _paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="https://XXX.XX.X.XXX/piwik/";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
  })();

</script>
<noscript><p><img src="https://XXX.XX.X.XXX/piwik/piwik.php?idsite=1&rec=1" style="border:0;" alt="" /></p></noscript>
<!-- End Matomo Code -->

Für ein paar Tips wäre ich wirklich dankbar.
Natürlich kann ich auch mehr Infos posten, wenn gewünscht.

Schöne Grüße :wink:


(Lukas Winkler) #2

Hallo,

Das sollte doch zum Laufen zu Bringen sein, vermutlich ist es nur eine Kleinigkeit:

Ich vermute, dass das eine Domain und keine reine IP-Adresse ist, oder?

Ich empfehle im Browser deine Webseite zu öffnen und in den Entwicklertools (F12) nachzuschauen:

  • ob ein Fehler in der Konsole ist
  • ob im Netzwerk-Tab erfolgreich piwik.js und piwik.php geladen werden können.

Wenn du willst, kannst du mir auch einen Link schicken, aber ich kann nicht versprechen es mir bald anzuschauen.


(Klaus) #3

Hallo, Danke für die schnelle Antwort.
Im Browser habe ich bereits nachgeguckt und keine Fehler entdecken können.
Matomo läuft momentan noch unter einer öffentlichen IP. Ich hatte einen Debian Server dafür aufgesetzt.

Ich schicke dir eine PN, mit dem Link.
Besten Dank schon mal!

–Kann es sein, dass ich dir keine PN schicken kann?–


(Roddy A. Stegemann) #4

Und die Version Nummer von PHP? Heißt sie jetzt 7.0?

Falls Sie sich diese Lösung zur Probe stellen, passen Sie bitte auf, daß alle ihre PHP Dokumenten noch richtig funktionierenl

Roddy


(Lukas Winkler) #5

Hi,

Ah, das ist der Spamschutz hier im Forum. Wenn man einen Account anlegt muss man X Minuten aktiv sein, dass man ein basic user wird.

Ich habe es jetzt manuell umgestellt