Matomo Self-Hosted Stopped Tracking After Caching & CDN Plugins Installed In Wordpress

I have a self hosted install of Matomo On Premise for my personal Wordpress blog on A2 Hosting servers. It has been working flawlessly for years, until recently. I just installed a caching plugin Comet Cache Pro & am using the Shift8 CDN plugin. My site has never been faster! Only problem is … Matomo stopped recording ALL hits. I get no info in my Matomo stats page. But if I check my Google Analytics page I can see hits for that day while Matomo records none.

I’ve used caching plugins before, as well as my own self hosted CDN setup for my Wordpress blog with no issues. If I remove my Matomo browser cookie I can get Matomo to record MY local hits from my Mac, but nothing from the outside world.

I’ll also be checking with support for both Comet Cache Pro & Shift8 CDN to see if this is a know issue, but I figured I’d also reach out to the Matomo forums first.

I’m flummoxed! Any ideas? Any hope? Any fix?

Thanks in advance for any input.


I am not sure if you changed anything since, but I can see the requests going to Matomo working properly.

If it still doesn’t work for you, temporarily enable and then check the request to matomo.php in your browsers developer tools.

It should respond with a verbose log indicating why the data has not been stored.

Hi Lukas …

Thanks for the response.

Yes I discovered that I needed to change a Comet Cache setting to NOT combine CSS/JS from remote sources. Once I changed that things started flowing again—I think.

I also did a reinstall of all the Matomo files on my server. Then a strange thing happened: I started getting the “Private Directories Are Accessible” error in the Matomo System Check Report. I ran the Apache web server fix & that solved that issue. But I don’t know why the error occurred in the first place. It never did before. ¯_(ツ)_/¯

So I’m not sure which fixed the issue. Bottom line … it’s working fine now.

Any guess why I started getting the private directories error, and never did before? I’m hoping I don’t have to do the server fix after every auto-update now.


The check for private directories has only been added in the last Matomo update, so that’s why it is shown now to some people and never before.