Matomo on Hostinger Shared Hosting

I’m on the premium shared hosting plan.
I installed Matomo 3.8.1 from the software available in Hostinger’s custom cPanel. I’ve had issues with Matomo not loading the dashboard or visitor log.

Perhaps because hostinger support enabled the php setting shell_exec, I am now able to get the page to load with CTRL-F5, about half the time.

In the System Check report:
" It is recommended to configure a ‘max_allowed_packet’ size in your MySQL database of at least 64MB. Configured is currently 16MB. "
Is that the problem?

error_log file has many instances of:
" Error in Matomo: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away "

Another consequence, is that I am unable to automatically update Matomo.

It might be. A lot of people reported that a too small max_allowed_packet setting caused the gone away issue for them and therefore we added the warning:

https://matomo.org/faq/troubleshooting/faq_183/

Is there an older version of Matomo that has a lesser requirement for “max_allowed_packet” size?

Hi,

The requirement never changed. It’s just that for a few versions there is now an info if is quite small.

But the 2006 MySQL server has gone away message is between MySQL and PHP so many things in the mysql config can be the reason.

As of yesterday, the Matomo loads the dashboard and visitor log without issues on the same hostinger account. I don’t know what they changed, but the matomo system check report still states that the max_allowed_packet size is 16MB. However, I am still unable to update Matomo, getting the same “MySQL server has gone away”.