Matomo Installation .DS_Store and php.ini post data

New to Matomo. Excited to start using it.

  1. After copying (still called) pikwik directory to analytics folder as instructed, I ran the usual Matomo self-check and got a message telling me that .DS_Store was corrupted and should be deleted. - No word about replacing the poor thing, so I did as instructed and deleted it.

  2. Ran the Matomo self-test again from:


and the got this message:

To prevent some critical issue, you must set the following in your php.ini file: always_populate_raw_post_data=-1
After making this change, restart your web server.

I can do this, but I’m worried about the deleted file in 1., above.

Please could an intelligent person tell me what I should do? Thank you! :slight_smile:


Don’t be afraid! :slight_smile:
.DS_Store is a file macOS creates when you open a folder in the file manager. It probably appeared after you unzipped the file, but before you uploaded everything to the server.
You can’t see it because most of the time files starting with a . are hidden.
Since a few versions Matomo has a checker that complains when it finds files that are lying around in its directory that don’t belong there, which caused the warning.

The always_populate_raw_post_data=-1 warning is because of a bug in PHP 5.6. Either switch to a newer PHP version or add the line to your PHP config.

I hope you are happy with Matomo,


Thank you Lukas. It’s clear, helpful responses such as yours, that make useful software a joy to use.

1 Like

May I ask, what permissions should be given to the pikwik (Matomo) directory as it is uploaded to the analytics directory on the server?

Currently I have settings as shown in attached image (7 4 4):



It depends on your server setup. The tmp/ always needs to be writable for the Webserver. All other depend on the features you are using.

But the system check should tell you if there is an issue (and if a needed folder isn’t writable you’ll see a detailed warning.