Matomo-Install scheint korrekt, aber Matomo zählt nichts?


(Manuel Wipfler) #1

Hallo zusammen,
ich habe letzte Woche einen neeuen Tracking-Code eine weitere Homepage erstellt, eingebaut (er wird angezeigt) und in meinem Matomo-Dashboard erfasst.
Während meine erste Seite dort wunderbar erfasst wird, zeigt die neue Seite jedoch keinerlei Ergebnis (0 Besucher) an?

Gibt’s eine Möglichkeit der Fehlersuche? Oder darf man Euch die Domain zur Überprüfung des Tracking-Codes hier angeben?

LG Manuel


(Fabian Dellwing) #2

Wenn du kein Problem damit hast, das auch andere die Domain lesen können kannst du sie direkt hier posten. Andernfalls kannst du sie als PN schicken, allerdings muss dir dafür vorher jemand eine schicken auf die du Antworten kannst.

Also, am besten einfach sagen, wie du es gerne hättest dann schauen wir es uns an.


(Lukas Winkler) #3

Hallo, @manuelwipfler, ich habe deinen Account umgestellt, du kannst jetzt direkt jemanden schreiben.


(Manuel Wipfler) #4

Bisher funktioniert das Tracking für die Website http://lgv.org sehr gut!
Die neu ergänzte Homepage hat die Adresse http://er-fuellt.lgv.org.

Die Piwik-Installation liegt auf dem gleichen Server im Verzeichnis Sign in - Matomo.

Dort habe ich das Dashboard aufgerufen und habe bei den Einstellungen die neue Homepage ergänzt. Sie wird dort auch angezeigt. Allerdings fehlt bei dieser in der Übersicht die Ergänzung: “Interne Suche: ja”???

Gerne sende ich Euch noch weitere Angaben, die Euch bei der Suche nach dem Fehler behilflich sind!


(Lukas Winkler) #5

Hallo,

Ich habe es ausprobiert und kann keinen Fehler finden. Die Daten werden ordentlich zum Server gesendet.

Kleiner Tipp (der aber nichts mit dem Problem zu tun hat):

Ich empfehle anstelle von

var u="//lgv.org/piwik/";

lieber

var u="https//lgv.org/piwik/";

zu verwenden. Denn da dein Matomo-Server per HTTPS erreichbar ist, kannst du so die Daten direkt per HTTPS schicken (ansonsten werden sie per HTTP geschickt und weitergeleitet).


(Manuel Wipfler) #6

Vielen Dank für diesen Tipp, das werde ich gleich umsetzen!
Ich habe auch den Eindruck, dass “eigentlich” alles funktionieren könnte …,
aber weil in der Ereignisliste nichts ankommt, bin ich ja so unsicher!


(Lukas Winkler) #7

Hallo,

Falls alles nichts hilft, kannst du mal kurzzeitig das aktivieren:

https://developer.matomo.org/api-reference/tracking-api#debugging-the-tracker

Dann gibt Matomo exakt aus, warum ein Besuch nicht gespeichert wurde.


(Manuel Wipfler) #8

Werde ich gleich tun!
Zur Sicherheit: Das Tracking der LGV.org. fuktioniert ja hervorragend. Aber die Seite http://erfuellt.lgv.org wird leider nicht abgefragt oder begutachtet!


(Manuel Wipfler) #9

Ich habe die Anweisung debug = 1 mal in die Datei config.ini.php eingefügt und habe die Seite aufgerufen!
Aber leider werde ich nicht ganz schlau daraus, wo ich jetzt die Debug-Einträge auslesen kann!?


(Manuel Wipfler) #10

Aha, ich habe jetzt folgende Fehlermeldung entdeckt:
Systemprüfung:
Fehler: Benötigte PHP Konfiguration (php.ini)
Warnungen: Dateiintegrität

Weiter unten ist zu lesen:
Benötigte PHP Konfiguration (php.ini)
session.auto_start=0
always_populate_raw_post_data=-1

Um schwerwiegende Probleme zu verhindern, sollten Sie Folgendes in Ihrer php.ini setzen: always_populate_raw_post_data=-1
Nach dieser Änderung müssen Sie den Webserver neu starten.

Okay, das würde ich sehr gerne machen! Aber wo befindet sich denn diese php.ini?
Und wie kann ich denn unseren Shared-Webserver “neu starten”???


(Lukas Winkler) #11

Hallo,

Um das zu bearbeiten, musst du den Support von deinem Hoster freundlich fragen. Das ist auf jeden Fall hilfreich, aber nicht das Problem.

Denn dieses habe ich gerade, dank dem debug gefunden. Wenn du die piwik.php-Anfrage in den Browser-Developer-Tools öffnest, kommt diese Antwort:

DEBUG: Debug enabled - Input parameters: 
DEBUG: array (
DEBUG:   'action_name' => 'ER-FÜLLT 2018',
DEBUG:   'idsite' => '2',
DEBUG:   'rec' => '1',
DEBUG:   'r' => '752322',
DEBUG:   'h' => '18',
DEBUG:   'm' => '41',
DEBUG:   's' => '42',
DEBUG:   'url' => 'http://er-fuellt.lgv.org/',
DEBUG:   '_id' => 'bbc4cfa1f9da4d22',
DEBUG:   '_idts' => '1524588096',
DEBUG:   '_idvc' => '1',
DEBUG:   '_idn' => '0',
DEBUG:   '_refts' => '0',
DEBUG:   '_viewts' => '1524588096',
DEBUG:   'send_image' => '1',
DEBUG:   'pdf' => '1',
DEBUG:   'qt' => '0',
DEBUG:   'realp' => '0',
DEBUG:   'wma' => '0',
DEBUG:   'dir' => '0',
DEBUG:   'fla' => '0',
DEBUG:   'java' => '0',
DEBUG:   'gears' => '0',
DEBUG:   'ag' => '0',
DEBUG:   'cookie' => '1',
DEBUG:   'res' => '1920x1080',
DEBUG:   'gt_ms' => '614',
DEBUG:   'pv_id' => 'WwlqsJ',
DEBUG: )
DEBUG: Current datetime: 2018-04-24 16:41:56
DEBUG: Executing Piwik\Plugins\CoreHome\Tracker\VisitRequestProcessor::manipulateRequest()...
DEBUG: Executing Piwik\Plugins\Actions\Tracker\ActionsRequestProcessor::manipulateRequest()...
DEBUG: Executing Piwik\Plugins\Goals\Tracker\GoalsRequestProcessor::manipulateRequest()...
DEBUG: Executing Piwik\Plugins\Ecommerce\Tracker\EcommerceRequestProcessor::manipulateRequest()...
DEBUG: Executing Piwik\Plugins\SitesManager\Tracker\SitesManagerRequestProcessor::manipulateRequest()...
DEBUG: Executing Piwik\Plugins\CustomVariables\Tracker\CustomVariablesRequestProcessor::manipulateRequest()...
DEBUG: Executing Piwik\Plugins\Heartbeat\Tracker\PingRequestProcessor::manipulateRequest()...
DEBUG: Executing Piwik\Plugins\CoreHome\Tracker\VisitRequestProcessor::processRequestParams()...
DEBUG: DoNotTrack header not found
DEBUG: Unknown URL is not allowed to track.
DEBUG: Visitor excluded.
DEBUG: -> aborting due to processRequestParams method
DEBUG: -> Scheduled tasks not triggered.
DEBUG: Next run will be from: 2018-04-24 16:48:05 UTC
DEBUG: Nothing to notice => default behaviour
DEBUG: End of the page.
DEBUG: array (
DEBUG: )
DEBUG: Time elapsed: 0.030s

Die wichtige Zeile ist DEBUG: Unknown URL is not allowed to track.
Ich vermute, dass du in der Webseiten-Verwaltung in Matomo die URLs eingeschränkt hast, aber http://erfuellt.lgv.org nicht dabei ist.


(Manuel Wipfler) #12

DAS WAR DER ALLES ENTSCHEIDENDE HINWEIS!
Diese Homepage heißt tatsächlich http://er-fuellt.lgv.org,
es war also der banale BINDESTRICH, der das Tracking unmöglich gemacht hat.

Und weil wir auch noch eine Weiterleitungs-Subdomain http://erfuellt.lgv.org auf diese Seite haben, konnte ich die Seite zwar aufrufen, aber das Tracking hat irgendwie dennoch nicht funktioniert!

Ich danke Dir/Euch sehr herzlich für Eure großartige Hilfe! Macht weiter so!!!