Matomo fails to connect to MariaDB if SSL is enabled

Hello All,
We are running Matomo on an Azure AKS infrastructure connected to an Azure MariaDB. Due to security requirements, we enabled Force SSL on our MariaDB with SSL v1.2 but since the change, the Matomo pod doesn’t startup due to a Database connection error:

Welcome to the Bitnami matomo container
Subscribe to project updates by watching
Submit issues and feature requests at
INFO ==> ** Starting Matomo setup **
WARN ==> The Apache configuration file ‘/opt/bitnami/apache/conf/httpd.conf’ is not writable. Configurations based on environment variables will not be applied.
matomo-75f4c9c4b7-sqrxv matomo realpath: /bitnami/apache/conf: No such file or directory
INFO ==> Configuring PHP options
INFO ==> Setting PHP max_execution_time option
INFO ==> Validating settings in MYSQL_CLIENT_* env vars
INFO ==> Ensuring Matomo directories exist
INFO ==> Trying to connect to the database server
ERROR ==> Could not connect to the database

Here are my Matomo settings for the SSL:

    value: "yes"

Any help will be greatly appriciated