Matomo does not work with php 7.2


#1

I downgraded from 7.2 to 7.1 to be able to upgrade to the latetst version of Matomo (3.6.0).
When I changed php to 7.2 again the matomo website generates a white screen.

The differrence between php 7.1 and 7.2 that seems relevant is mcrypt as php extension: it is available at php 7.1 and not at php 7.2

Can you confirm that this generates the issue reported? And if not: is there any advice on how to solve the issue other then downgrading to php 7.1?

Thank you.

Greetings,
Paul


(Fabian Dellwing) #2

You can still get mycrypt for PHP 7.2. See e.g. How to install mcrypt in php7.2 | Lukáš Mešťan

To tell you exactly what goes wrong with PHP 7.2 we would need to see the error from the error_log after the wsod is generated.


(Lukas Winkler) #3

Hi @onderzoekspraktijk,

I am using Matomo with PHP 7.2 in production for quite a while now. While the tests are not yet running with 7.2 and therefore it isn’t “officially” supported, there shouldn’t be any errors with 7.2 anymore.


(Pak Kriss) #4

A couple of weeks ago we run in issues with php 7.2 and matomo (all std. and all premium plugins enabled) and it turned out one or two plugins wasn’t 7.2 ready. So we are back to 7.0 or 7.1. Since it’s a while ago I cannot remember details nor I know the current 7.2 compatibility of Matomo across all plugins. We will review this case at the end of the year.


#5

Well: I can confirm that Matomo version 7 still refuses to work with php 7.2.

White screen of Death Galore!

error message:
Fout bij laden van deze URI: Could not load the source for https://…/index.php?module=Installation&action=systemCheckPage&idSite=5&period=range&date=last30&showtitle=1&random=5207.
[Exception… “Component returned failure code: 0x80470002 (NS_BASE_STREAM_CLOSED) [nsIInputStream.available]” nsresult: “0x80470002 (NS_BASE_STREAM_CLOSED)” location: “JS frame :: resource://devtools/shared/base-loader.js -> resource://devtools/shared/DevToolsUtils.js :: onResponse :: line 568” data: no]
Stack: onResponse@resource://devtools/shared/base-loader.js -> resource://devtools/shared/DevToolsUtils.js:568:25
onStopRequest@resource://gre/modules/NetUtil.jsm:126:17
Line: 568, column: 0

I tried to discover more, but error messgaes are not very visible at all.
I do hear from others that they also still run Matomo in php 7.1 because “otherwise it dont work”.

Really not sure what to do: check other solutions or keep using soon to be outdated PHP?


(Lukas Winkler) #6

Hi @onderzoekspraktijk,

I (and many other people) are running Matomo with 7.2 for more than half a year in production (and apart from a few warnings Matomo works with 7.3)

If you are getting PHP errors, then please check the PHP error log and report the errors you see there.

The error you are reporting (NS_BASE_STREAM_CLOSED) doesn’t have anything to do with Matomo or PHP, but occurs in your browser and is possibly based on an Firefox bug:



#7

Thanks! I will look into it.