Matomo does not show visitors almost at all


#1

matomo does not show visitors almost at all, although there are many on the site.

what can I do about it?

Thanks


(Fabian Dellwing) #2

A bit more information are needed to help you.

Do you see any visits in the real time visitor widget? If not, would you kindly provide me the URL to your page that you are tracking via DM.


#3

Thanks.

Today have gone to the site at least 8 different visitors.
(I do not found on your forum tools, to attach a screenshot)
And matomo shows only 2.

my sites:
piwik.geschichte-chronologie.de (as matomo)
for
ru.geschichte-chronologie.de


(Fabian Dellwing) #4

You have no valid SSL certificate for your Matomo instance, so the browser is simply killing this request and it will never track anything. Please deploy a valid certificate and it should start working.


#5

Thanks.
I removed force_ssl = 1 from config.ini.php file.
Now a Site Call http://piwik.geschichte-chronologie.de does not use https.
Unfortunately, nothing has changed. matomo today shows 1 visitor instead of 7.
What else can I do, please?


(Lukas Winkler) #6

Hi,

It is a fundamental pricible of how websites work, that Websites served via HTTPS can never embed content from HTTP pages, as it would make it possible to circumvent all security.

Therefore if you want to track a HTTPS site you must have HTTPS enabled on Matomo for it to work.

In addition if you set up Matomo without HTTPS you can never guarantee that the data is really store privately as everyone else can read it on the way to your server.

Thankfully setting up HTTPS is really easy and free thanks to Let’s Encrypt and co.


#7

Thank you very much.
It works now.