Matomo client: Visitor tracking not correct though tracking in WP admin dashboard seems correct

Visitor statistics in wordpress admin dashboard seem to be correct, but matomo client is only showing a fraction of it.

I’m running Matomo on the same server (all-inkl hosting package) as the website and I am using the option self-hosted PHP API to connect wordpress (plugin connect matomo) to the matomo instance. I updated my website to PHP 8.2, matomo still running on 7.4.
WP-Matomo 1.0.30 / Matomo 5.0.0-rc8 / WordPress 6.4.1.

System check in matomo client shows the warning that PHP should be updated since 7.4 is not recommended anymore. And it shows this error:
LOAD DATA INFILE failed… Error was:
Try #1: LOAD DATA INFILE : SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user ‘d037ccb0’@‘localhost’ (using password: YES)[28000],
Try #2: LOAD DATA LOCAL INFILE : SQLSTATE[HY000]: General error: 4166 The used command is not allowed because the MariaDB server or client has disabled the local infile capability

Any idea how I can solve this?

just to mention: same behaviour with matomo 4.15

Hi @werderbremen
Can you check configuration file, especially on:

  • enable_load_data_infile
    And maybe?
  • live_query_max_execution_time
  • archiving_query_max_execution_time

Hi @heurteph-ei

enable_load_data_infile = 1
live_query_max_execution_time = -1
archiving_query_max_execution_time = 7200

config.ini.php: no relevant entries

any ideas what should be adjusted?

Hi @werderbremen
Can you try enable_load_data_infile = 0?

Thanks for your assistance, but I reinstalled matomo from scratch and it seems to be working right now.

1 Like