Matomo causes errors (and some hosts block my IP as a consequence)

Hi! I don’t seem to get any answer in the Wordpress forum, so I am trying here instead. I will quickly summarize the issue, there is more information in the thread linked below.

Matomo causes errors on all installations (Matomo plugin on Wordpress), and some hosts, correctly, decide to block my IP for a while due to this.

The error log shows following: (I have anonymized the error log by replacing my IP with XXX and the domain with yyy.yy)

[Tue Sep 05 08:28:16.737849 2023] [authz_core:error] [pid 239246] [client XXX:0] AH01630: client denied by server configuration: /var/www/vhosts/yyy.yy/httpdocs/wp-content/plugins/matomo/app/config/global.ini.php

The plugin support asked me to add a line of code into the config file, which solved the issue. As I expected, the line of code dissappeared in the last update and the errors are back again.

I need a durable solution to this issue. Are you working on a solution? Is the problem known? Anyone else sees this issue in their errorlogs?

See also this thread for more information.

Hi @naturligtvismedia

Which line of code and into which the config file?
Indeed, there is a config file dedicated to personal settings, you have to update this one…


All the details are described in the linked thread:

This is where I added the line of code:
" Hello Anna. Sorry for the late response. Upon replicating the issue, it should be added to common.config.ini.php .
The path should be: /wp-content/plugins/matomo/config"

If you cannot read the linked thred from the Wordpress forum, I will describe the issue in more detail by copying the answers from that thread.

Hi @naturligtvismedia,
Does the file config.ini.php also exist in your Matomo? This is the config file used to store the instance specific configuration, then you can add your line in this file…
(I don’t understand why your common.config.ini.php file is also overwritten, because the default config file, overwritten by updates should be global.ini.php).

This are the files in the config folder that your colleague in the Wordpress forum suggested. They were all updated when I updated Matomo to 4.15.2 on October 13th.
Skärmbild 2023-10-24 121000

And this is where the error happens:
[Tue Oct 24 11:08:08.122639 2023] [authz_core:error] [pid 36952:tid 140125128296192] [client XXX] AH01630: client denied by server configuration: /srv/www/XXX/www/wp-content/plugins/matomo/app/config/global.ini.php
(partly anonymized by replacing with XXX)

Hi @naturligtvismedia
The screenshot does not correspond to the error message… is it just a copy/past problem?
In config files you displayed, can you see some specific configuration, like database access, etc.?
Can you try to add config.ini.php file (with the desired personal configuration) in this folder or in the same folder as global.ini.php?


The screenshow shows the files in the folder where your colleague at the Wordpress forums adviced me to put the line of code into the file common.config.ini.php - but all of these files where updated in the last update of the plugin.

Then I pasted the error message.

These are the first 12 lines in the file …/wp-content/plugins/matomo/config/common.config.ini.php
; <?php exit; ?> DO NOT REMOVE THIS LINE
; Configuration settings which are applied to all Piwik instances.

adapter = WordPress

tracker_cache_file_ttl = 4385

enable_update_communication = 0
enable_auto_update = 0

To clarify: you want me to try to add an empty file named “config.ini.php” in one of the paths at the time with the following line of code only?
enable_required_directories_diagnostic = 0

Hi @naturligtvismedia

Yes, this is my suggestion… I would suggest to try first with the path provided by the error message…

I tried it and it doesn’t work in either of the paths. The error messages still persist.

Your colleague at the Wordpress forum opened a Github issue folowing this topic, you find it here:

1 Like